Sorry that went out prior to my pasting in more info.

 

From: Joey [mailto:Joey@Web56.net]
Sent: Friday, October 17, 2008 8:31 PM
To: 'fail2ban-users@lists.sourceforge.net'
Subject: problem running script

 

Hello All,

 

This doesn’t make any sense but here it goes.

I was running fail2ban just fine when I got a patch from Cyril, I tried to compile it but in the end it didn’t work.

I backed out my change and re-compiled but it wouldn’t execute properly.

No problem, I untarred a new copy ran the python setup.py install and still no luck.

I then removed anything that said fail2ban on the whole server, un tarred a new copy compiled and still no luck.

It makes no sense and this is what I get when trying to run the client.

 

 

  File "/usr/bin/fail2ban-client", line 40, in ?

    from client.beautifier import Beautifier

  File "/usr/share/fail2ban/client/beautifier.py", line 27, in ?

    from server.jails import UnknownJailException

  File "/usr/bin/server.py", line 28, in ?

    from jails import Jails

ImportError: No module named jails

 

The above is the error I get doing anything with the client.

I am using configuration files I have running on another box, so it’s not a config issue, but I am really stuck as to what is going on.

 

 

Joey.