system crashing 1.1b1 - help?

  • I installed ext2fsx 1.1b1 last night and had success mounting an ext3 external firewire drive.  then, with no other changes, my system (fully-patched panther) started crashing every few minutes.  i removed the firewire drive and the system would continue to crash after being up about 5 minutes.  i gave up.

    then this morning i booted and quickly removed ext2fsx before it crashed.  i then rebooted on purpose.  my system is _still_ crashing approximately 5 minutes after booting, whether i log in or not. 


    btw, never install new software on the only machine where your critical project resides and you need to work on it that day!  omg, i thought i would have learned this lesson by now.


    any help would be so appreciated...

    • I assume by "system crashing", you mean a kernel panic (the multi-language transparent overlay that tells you to reboot your machine). Do you have a /Library/Logs/panic.log file? If so, please send it to me: bbergstrand at users dot sourceforge dot net.

      I did just fix a panic yesterday in 1.1b1, but if you've uninstalled the driver, then it's pretty much impossible for ext2fs to cause the problem.

      Can you boot into "safe mode". You do this by holding down the shift key while the computuer boots.

    • Followup:

      Turns out ext2 was the circumstantial cause of this panic. The real culprit is Symantec's Norton Systemworks.

    • I removed Norton Utilities and have not had a panic yet.

      Since I would be required to upgrade to Norton Utilities 8.0 soon anyway, I may take this as a chance to change to another software providor for disk health.  The native OSX utilities don't seem to be adequate for my situation.  Any recommendations?

      • If you have Panther, and have journaling enabled, then there should be no need for third party disk utils. I crash my test/debug machine all the time, and have never even run fsck, let alone Disk Doctor, or any other repair program (not true for ext2/3 on OS X -- you must run fsck_ext2 after a crash).

        That being said, I think you can use Disk Doctor w/o the symantec kernel extensions. Alternatively, I've always heard good things about Disk Warrior. And if you get in real trouble (disk is completely hosed), Prosoft's Data Rescue will supposedly work when nothing else will.


    • Hi there

      I seem to be encountering a kernel panic as well, however only when I try to mount a ext2 partition. I am using the 1.1b1 release on OSX 10.3.2 and the mounted partition is on a FireWire external Drive.

      I have been using this release for quite sometime now, and I never had a problem with it (except that the partition's name only displayed sometimes).
      I recently applied Apple's newest Security update... Is there any known co-relation with this?
      Also there have been a couple of times where I managed to mount, use and then umount the partition without any problems (through shell commands).
      I am trying to find the pre-requisites to a successful mount, in the hope it helps diagnosing the problem...


      • Well, I'd need to see the panic.log file to tell you if ext2fs is involved, and if so what the problem is. Any chance you can send it to me? It's located in /Library/Logs/panic.log.

        That being said, I did recently fix a panic in 1.1, but it is rare and should never happen unless the disk is physically damaged. If you want to give it a try, I've posted it to:

        Let me know ASAP if you still have panics with this version. And please don't forget about the panic log file.


    • Hi there

      Sorry for the late reply I was on the road...

      I think I found what caused the panic, before I started having the trouble I had the FireWire disk connected to a box that I booted using the trinity rescue kit (Mandrake running off CD),
      There was no crash or anything else that might have suggested  that the filesystem might have been damaged.
      However, after having tried to run fsck on that partition without success from my mac I did it through TRK on a friends PC and ever since I have not encountered a single panic.

      - Crumbler

      • I'm glad things are working now. It surprises me that fsck on OSX had problems when Linxu worked. They are basically the same program. Weird.

    • Maybe I did something wrong? I used fsck_ext2 -fy on the mac, but it made no difference. The partition's ext3, can  that be the problem? But then, I successfully fsck'd this partition on earlier occasions...