system crash - help

  • Nobody/Anonymous

    I've got a USB external disk formatted in the Linux Ext2 File System.  I installed EXT2FS V1.3 on my MAC OS 10.2.8 system and mounted the disk.  For a couple of times, it worked fine, my system mounted the disk using the mount option of the EXT2FS manager and everything worked fine. 
    At a given moment, my system automounted the disk (it may be that I choose that option on the EXT2FS manager, I'm not sure).  My sytem crashed and I had to restart it.  Since then, when I try to mount the external disk I'm told that I need to repair it (but it works fine on my LINUX box sitting by the side).  Furthermore, as I connect the external disk on the USB spot, the computer starts fsck_ext2 that gets more of my G4 processor CPU and any program I try to run (e.g., "Disk Utility") is hang up. 
    I got a /Library/Logs/panic.log that makes reference to ext2_cmap ... possible filesystem corruption, as well as a /Library/Logs/CrashReporter/autodiskmount.crash.log that I can make available if it helps solving this problem. 

    • Nobody/Anonymous

      The crash is a known (but perhaps unfixable?) problem with ext2 and OSX with USB. It is normal that fsck_ext2 runs when you plug in the disk. The fsck_ext2 is a program that checks if the disk is OK. You may have to wait until that program has finished before you can do something with the disk yourself.

      Your disk has slightly corrupted because of system crash. You can fix the disk in OS X by running in Terminal:  fsck_ext2 -fy /dev/diskXsY    ----where X and Y are the numbers of the disk and partition of the EXT2 volume. This allows you to access the disk normally.

      HOWEVER, writing to that disk in OS X very often causes the system crash you experienced. USB is not stable, use Firewire, it works.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks