Unable to write on EXT2 (10.4.8 with 1.4d4)

  • Nobody/Anonymous

    Hy, I'm trying to mount an external USB disk containing a EXT2-filesystem, however I can only get read-only access to it. I tried using the 'ignore-permission' switch, but to no effekt. I then tried setting ownership with chown, but I only get a 'Permission denied'. Is there some other way I could try getting the disk to be writable?
    Thanks in advance.

    • Nobody/Anonymous

      Same for me, the filesystem is mounted read-only
      on Macbook Pro 10.4.8

      But great work !

      Bye Marc

    • Nobody/Anonymous


      I've experienced the same issue with a partition to be shared between Mac OS X and Debian, on a macbook core 2 duo.
      The trouble may come from the "indexed directories" property of the ext2/3 fs. As said in the README, the driver has not be stressed with this option, and conservatively loads partitions with indexed directories as RO.
      To solve this issue, I did rebuild a filesystem on this partition under linux with mkfs.ext3 -O none (this cause to not use indexed directories, neither any specifics of the fs).
      Beware of creating a ext2 filesystem with this mkfs option: I got a kernel panic under mac os X on the first restart. It seems better with ext3, even if the solution is not totally satisfying...

      Hope this helps.

      And, developers, congrats for this driver, and really looking forward the final realease with support of indexed directories for RW ;)



    • Nabil Sayegh

      Nabil Sayegh - 2007-02-23

      You don't need to format your hdd to remove journaling:
      tune2fs -O ^has_journal /dev/foo

    • Nabil Sayegh

      Nabil Sayegh - 2007-02-27

      Actually, you also need to disable directory indexing:
      tune2fs -O ^has_journal,^dir_index /dev/foo

    • Nobody/Anonymous

      I have the same problem...but the problem is...I used to be able to write to my EXT3 partition with 1.4d3!! However, I installed 1.4d4 and saw some comment said it kill drive...so I downgrade to 1.4d3. That's how it doesn't mount as RW mode.

    • DJ Kouza

      DJ Kouza - 2007-06-05

      I have had success with only using tune2fs -O ^dir_index /dev/foo   leaving the journaling on.

    • Nobody/Anonymous

      Hello all

      I haven't not yet tried commands suggested by others here.
      Here is what I have:
      Initially I used to tripple boot my intel macbook: Mac, Vista, XP
      I later reformated the XP partition to ext3 to install Ubuntu 7.x
      Note that Mac still sees that linux/ext3 partition as 'Microsoft basic data'
      I had mistakenly installed 1.3d, later installed the 1.4d4.
      now my ubuntu/ext3 partion got automounted on reboot.

      The ExtFSManager still shows volume IOKit Name as 'XP' (which I had originally used)
      though the volume name is shown as 'Ubuntu'
      The ExtFSManager is showing 'Writable: No' to my ubuntu partition.

      Can anybody help me out here to get this ubunut/ext3 partition writable (or
      the above commands are only solution for now) ?

    • ulti7ubuntu

      ulti7ubuntu - 2007-09-11

      Hey.  I'm trying to get my wife's mac to talk to my external hard drive that I formatted with ext2.  I'm running Ubuntu on my Linux machine (Feisty Fawn) and she's got 10.4.10 on her Mac.  I installed vers 4d4 and I can now read the drive but currently have no write capabilities.

      I'm a noob at both Linux and Apple (worked in Software for 10 years in @$#! Windows) but I'm getting around okay with a LOT of research.  Anyway I attempted to turn off journaling and indexing on my external drive and got this message:

      The command:   tune2fs -O ^has_journal DiskExt
      tune2fs 1.40-WIP (14-Nov-2006)
      tune2fs: Is a directory while trying to open DiskExt
      Couldn't find valid filesystem superblock.

      The command:   tune2fs -O ^dir_index DiskExt
      tune2fs 1.40-WIP (14-Nov-2006)
      tune2fs: Is a directory while trying to open DiskExt
      Couldn't find valid filesystem superblock.

      I also tried
      The command:   tune2fs -O ^dir_index ./DiskExt
      Couldn't find valid filesystem superblock

      Anyone see what I'm doing wrong?  (I'm sure it's noob-y-ness.)

    • Joseph Fannin

      Joseph Fannin - 2007-10-31

      It is not necessary to remove the journal, only the dir_index feature -- `tune2fs -O ^dir_index /dev/devicename` .  It's safe to run this against a mounted volume -- the new settings just won't take effect until the next time the filesystem is mounted.

      After running that command, it's important that you run a full fsck against the filesystem before you mount it again!  You must do this whether the volume was mounted or not when you ran tune2fs, or you could corrupt your filesystem.

      Be sure to pass '-f' to your fsck so that a full check is done, since fsck doesn't normally think it necessary to do a full check on a filesystem that has a journal.  And don't ever run fsck against a mounted filesystem.

      So, something like:  `e2fsck -fDC0 /dev/devicename` with the filesystem unmounted.

      It is not necessary to disable journalling.  The only time ext2fs will see the journal is when the filesystem hasn't been cleanly unmounted -- in which case the solution is to run e2fsck to replay the journal, (or boot Linux and shut it down properly this time).

      ulti7ubuntu, you need to specify the device node for your filesystem instead of any variation on "DiskExt".  Look in the file /etc/fstab if you're not sure what it is, you should be able to work it out.

      If you're running a recent version of Ubuntu, /etc/fstab will probably have UUID= stuff rather than the device node paths, but I believe tune2fs can work with those too, you'll end up with something like:

      `sudo tune2fs -O ^dir_index UUID=abunchofgobledygook!!!!11one

      Then do a `sudo touch /forcefsck` and reboot back into Linux -- that'll cause a full fsck of all your filesystems during the next boot.


Log in to post a comment.