mounting with read permission

Help
2006-03-30
2013-05-02
  • Anders Storsveen

    I'm as stated earlier having problems with the UI, so I have to mount it via CLI. But how do I mount it so that I can actually read whats on there as a user? I've tried umask, uid, gid and nothing works! :((

     
    • Brian Bergstrand

      Mapping UID/GID is a tricky process. You could try the "Ignore Permissions" option in the pref pane, but I'm not really sure if that works on Tiger. Your only other option is to access the disk as root.

       
    • Nobody/Anonymous

      I'm not using the permissions thing, since I'm using the CLI as mentioned earlier. What excactly does the extmngr call mount with when Ignore perms is on. I tried looking in the CVS, but didn't find anything... :/

       
    • Brian Bergstrand

      The pref pane sets a key in the global prefs file (/Library/Preferences/net.sourceforge.ext2fsx.ExtFSManager.plist) and mount_ext2 reads that pref file. There is no argument to mount_ext2 to ignore perms.

       

Log in to post a comment.