Strange issues running OS X Tiger 10.4

  • My Ext USB2 drive will not mount on my mac anymore. Befrore the upgrade I sometimes had to plug into a linux box fsck it then it would mount.

    I have tried forcing fsck_ext2 runs then says all is good. If I run fsck -p says it cant find superblock.

    I get an error when trying to use gui to mount.
    I'm not sure of exactly the syntax to mount cmd line. seems a bit different than linux here. Any help is appreciated. Drive is 160Gb formatted Ext2

    Thanks in advance for any assistance,

    • BTW -- Drive works perfectly in Slackware, Redhat and Sun Java Desktop (SUSE)

    • Drive is viewable with no issues when running from Virtual PC (XP Home) running Windows project on my G4 laptop.

      Drive works everywhere except in 10.4, worked great in 10.3 (well after playing and fsck'ng around.)

      • That's the problem. The ext2 driver is not supported on 10.4. Apple totally changed the kernel interfaces in 10.4 and a lot of work will be needed to get the driver running  -- and I don't have the time right now to do much.


    • Is there anyway to force a mount or "trick" it into mounting?

      • No. The current driver is totally incompatible with the changes Apple made in 10.4. Without the driver, it is impossible to mount any ext2 file system.

        If you are desparate, you could use debugfs on the raw device and copy files to your hard drive that way, but it is in no way a "user friendly" option.

    • Never used debugfs before but I am pretty desperate. I have several 40GB forensic drive images I need to get access to from my powerbook. I converted equipment to have ext2 drive (160GB) in a dual firewire 800 enclosure with the other drive being HFS journaled 300GB

      I've searched and cannot find debugfs, where can I find this tool???

      Thanks Again

      • it's in /usr/local/bin

        But if you are that desperate, why not install Panther and then you can use the driver.