Help! Damaged drive?!

  • Nobody/Anonymous

    I have a 160GB LACIE d2 Hard Drive "Extreme" with 100GB of important, Linux-formatted data on it.  I am running 10.4.11 on a PowerBook G4.  I connected the drive to my laptop with the USB 2.0 cable.

    I downloaded Mac OS X Ext2 Filesystem so that I could mount the disk.  I installed the software, and rebooted.

    After I came back from lunch, it had all worked, and my drive was mounted.  EXtFSManager can see the disk, and reports:"Filesystem: Linux Ext3 (Journaled)"

    I then copied a couple of text files over to the drive to make sure things were working.  All seemed well.

    I then started a job which accessed the files on the drive.  Things were working fine.  About a half hour through the job, I turned my laptop for someone to see the monitor.  I got an error, and the drive was no longer accessible in the finder.  I jiggled the cables, but nothing happened.  Opening the EXTFS system panel, it can detect the drive, but not mount it.  It reads "Disk Error" and "Message:Disk not ready".  Disk Utility says: "1 non HFS volume detected.  Volume needs repair".

    I tried rebooting my machine, and reconnecting the drive.  Same result.  The drive is no longer accessible.

    Is my disk dead?  What the hell happened? 
    Have I lost all of my data because I trusted some freeware?!

    •  barokt

      barokt - 2009-01-05

      i have same problem, i used to do write option in my EXT2 HDD but after the copying one file and HDD write access no longer avaliable, i don't understand what's the problem i have to write some data in my EXT2 HDD anyone could you help me ?


Log in to post a comment.