unable mount due to "unsupported features"

  • William Nolan

    William Nolan - 2006-04-09

    I installed Ext2FS_1.4d2, and I'm running 10.4.6.

    When I try mount_ext2 as root, I get the following:

    /sbin/mount_ext2 -x /dev/disk1s2 /mnt/linux
    mount_ext2: /dev/disk1s2 on /mnt/linux: Invalid argument

    Log file in /var/log/system.log gives:

    Apr  9 17:10:48 william-nolans-computer kernel[0]: ext2fs: reading superblock from block 2, with size 1024 and offset 0
    Apr  9 17:10:48 william-nolans-computer kernel[0]: EXT2 WARNING: mount of unknown denied due to unsupported optional features (00000004)
    Apr  9 17:10:48 william-nolans-computer kernel[0]: EXT2-fs DEBUG (/Users/brian/Projects/Sourceforge/ext2tiger/src/gnu/ext2fs/ext2_vfsops.c, 468): ext2_check_sb_compat:Returning Error! (1)
    Apr  9 17:10:48 william-nolans-computer kernel[0]: EXT2-fs DEBUG (/Users/brian/Projects/Sourceforge/ext2tiger/src/gnu/ext2fs/ext2_vfsops.c, 950): ext2_mountfs:Returning Error! (22)
    Apr  9 17:10:48 william-nolans-computer kernel[0]: EXT2-fs DEBUG (/Users/brian/Projects/Sourceforge/ext2tiger/src/gnu/ext2fs/ext2_vfsops.c, 368): ext2_mount:Returning Error! (22)

    What documentation I've read of ext2 seems to suggest there's a flag in the superblock for incompatible features.  I checked ext2_vfsops.c in CVS for the error, and verified it was generating an error if there was a non-zero value for this flag.

    I'm pretty sure I have a standard ext3 fs, since I only ever used 2.4 RH 9 with it.  It may be that the flag got set to force an fsck by Linux before I tried to mount it on my Mac?  I know that's stretching :-).

    Would anyone suggest trying to use debugfs to clear the flag?  Has anyone had any experience with that?


    • Brian Bergstrand

      #define EXT3_FEATURE_INCOMPAT_RECOVER        0x0004

      From http://www.charmed.com/txt/ext2.txt:
      The ext3 RECOVER flag is needed to prevent a kernel which does not understand the ext3 journal from mounting the filesystem without replaying the journal.

      I'd say run e2fsck which will replay the journal and hopefully clear the flag.

      • William Nolan

        William Nolan - 2006-04-11

        Thanks for the tip, I will try that out.  By the way -- great work on this project so far!  Thanks for putting in all the time, definitely appreciated.

      • William Nolan

        William Nolan - 2006-04-12

        That did the trick!

        I ran an fsck on the drive and it replayed the journal, after which I was able to mount the drive and copy the necessary data off it.

        This worked perfectly.  Thanks again for your work on this project, much appreciated!


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks