Matt Wu - 2005-03-30

If you don't use the exe setup program to install ext2fsd 0.24, you'll get error message with setup.bat. I forgot to check it, just chcked the setup program.

Here I paste the updated content of setup.bat:

@echo off
if %1.==. goto help

set srcpath=nothing

if %1.==2k. set srcpath=w2k
if %1.==2K. set srcpath=w2k

if %1.==xp. set srcpath=wxp
if %1.==XP. set srcpath=wxp

if %srcpath%==nothing goto help

set cppath=nothing
if %2.==utf8. set cppath=utf8
if %2.==all. set cppath=all
if %2.==UTF8. set cppath=utf8
if %2.==ALL. set cppath=all

if %cppath%==nothing goto help

copy %srcpath%\%cppath%\ext2fsd.* . >NUL
rundll32.exe setupapi.dll,InstallHinfSection DefaultInstall 132 .\Ext2fsd.inf
net start ext2fsd
goto exit

:help
echo Help on ext2fsd setup utility:
echo setup 2k utf8: to install ext2fsd (utf8 version) for windows 2000
echo setup 2k all: to install ext2fsd (all codepages version) for windows 2000
echo setup xp utf8: to install ext2fsd (utf8 version) for windows xp
echo setup xp all: to install ext2fsd (all codepages version )for windows xp

:exit