Bug 0.25 - 0.31 Files trucated WXP Pro

  • Nobody/Anonymous

    I backed up many GBs of files to an ext2 partition using ext2fsd 0.25 (hoping to ditch windoze and move to GNU/Linix without being stuck with an NTFS partition.)
    I have noticed with 0.25, 0.25a, and 0.31 that  many of the large files have been truncated - archives have only a few of the original files in them, 800MB files come are reported as 6MB, etc.
    As there was a bug up to v0.3 that file sizes were reported incorrectly, is it possible that the wrong sizes reported by 0.25 during backup caused copying to be aborted prematurely, and hence the data is irrevocably corrupt;  or is it possible that there is a filesystem error that could be fixed by some equivalent of the DOS FAT/NTFS command CHKDSK /R ?
    Thanks for all your work.

    • Matt Wu

      Matt Wu - 2006-11-10

      You are using explorer to copy/backup or other sofeware ? How large of the file which was truncated, it's just plain data or other special files (sparse etc.) ?

      Could you access these files under linux system ? What are the reports of linux ext2/ext3 fs ?

    • Nobody/Anonymous

      Yes, I just dragged and dropped the files using Explorer, and I don't think they were sparse.
      The affected files were all a few tens of MB or more, but not all such files were affected - it seems fairly random.
      I'll have to test with eg Knoppix as I don't yet have a linux system installed.

    • Matt Wu

      Matt Wu - 2006-11-16

      0.25 version has problem of treating VDL (valid data length), that's why microsoft word (office) could not save file on ext2fsd volumes. 0.3x corrects many bugs of 0.25. I tried 0.30 and 0.31 to copy tens of GBs and diff them with the source before releasing.

      Do you have cygwin installed ? if so, you can dump the inode infromation of the truncated files with debugfs, or I'l write one and mail you.

      So we need inode information (i_size, content of i_block[]) to analyze whether i_size is wrong (the data is there and valid) or the file does not contain the data (which was truncated).

      • Nobody/Anonymous

        No Cygwin, only MinGW/MSYS which doesn't have debugfs.  I tried to compile e2fsprogs but no luck so if you have time my email is ivravii_blaise [att] yahoo [dott] co [dott] uk.
        Your help is greatly appreciated.

        • Nobody/Anonymous

          ivraviii_blaise [att] yahoo [dott] co [dott] uk.

    • Nobody/Anonymous

      I now have Debian installed on the affected machine.  What command shall I run to get the info needed?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks