SourceForge has been redesigned. Learn more.
Close

Problems with 1.8.3 patch

Help
2001-02-08
2001-02-11
  • Jeremy Hunt

    Jeremy Hunt - 2001-02-08

    When I apply expectpy-1.8.3.diff I get the following...

    patching file `ExpPyRE.c'
    Hunk #1 FAILED at 16.
    Hunk #2 FAILED at 197.
    2 out of 2 hunks FAILED -- saving rejects to ExpPyRE.c.rej
    patching file `expect.c'
    Hunk #1 FAILED at 16.
    Hunk #2 FAILED at 2209.
    Hunk #3 FAILED at 2231.
    3 out of 3 hunks FAILED -- saving rejects to expect.c.rej
    can't find file to patch at input line 111
    Perhaps you should have used the -p or --strip option?
    The text leading up to this was:
    --------------------------
    |Index: test/06pcre.py
    |===================================================================
    |RCS file: /cvsroot/expectpy/src/test/06pcre.py,v
    |retrieving revision 1.3
    |retrieving revision 1.3.2.1
    |diff -c -r1.3 -r1.3.2.1
    |*** test/06pcre.py     1999/04/19 13:56:02     1.3
    |--- test/06pcre.py     2000/11/02 13:05:08     1.3.2.1
    --------------------------
    File to patch:

    Any ideas would be appreciated.
    Sincerely,
    Jim J.

     
    • Michael P. Reilly

      Hi there.

      Could you please give the following to help you better:
      1.  what system you are on ('uname -a' should do);
      2.  what directory you were in (should be in the directory with the 'ExpPycnf.h.in' file); and
      3.  what command you ran to apply the patch;
      4.  what release are you applying the patch to (run 'grep VERSION patchlevel.h`)

      When/if patch asks for a filename, just enter the name at the prompt.  Patch sometimes has a problem with subdirectories.

      I've run this on RedHat 7, Solaris 2.x and FreeBSD 3.x with no problems.  I'd like to know where you trouble is.

       

Log in to post a comment.