installation issues on 64bit Ubuntu 10.04

James Choi
  • James Choi

    James Choi - 2011-09-26


    I've been wrestling to install expect and I'd greatly appreciate it if I could get some help.
    I'm running Ubuntu 10.04 64-bit and trying to install expect to a local directory (not root user).
    I've also installed tcl8.5 and tk8.5 to local directory /home/jchoi/tcl8.5

    After downloading expect5.45 and running
    ./configure -prefix=/home/jchoi/expect -with-tcl=/home/jchoi/tcl8.5/lib/ -with-tk=/home/jchoi/tcl8.5/lib/
    make install

    I get the following error:
    (echo 'if {![package vsatisfies  8.5]} {return}' ; \
         echo 'package ifneeded Expect 5.45 \
            [list load ]'\
        ) > pkgIndex.tcl

    I also tried with the same commands in which case I get this error:

    gcc -pipe \
              -Wall -Wno-implicit-int -fPIC \
             -Wl,-export-dynamic  \
            -o expectk exp_main_tk.o \
            -L/home/ubuntu/expect- -lexpect5.44.1.14 \
            -L/home/jchoi/tcl8.5//lib -ltk8.5 \
            -L/home/jchoi/tcl8.5/lib -ltcl8.5 \
            -lX11   -ldl  -lieee -lm \
            -Wl,-rpath,/home/jchoi/tcl8.5/lib \
    : expectk
    (echo 'package ifneeded Expect \
            [list load ]'\
        ) > pkgIndex.tcl

    Could anyone PLEASE help me with this? Thank you!

  • James Choi

    James Choi - 2011-09-26

    Small error on my previous post. Those errors occur when I do "make" not "make install"

  • ender

    ender - 2011-10-09

    Can you check out this and see if it helps?  It seems there may be some incorrect syntax.

  • Priyanka

    Priyanka - 2013-12-27

    Even i'm getting the same error when i run "make" on the fc15.
    Can someone please tell me how to handle this?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks