#52 compilation failure

closed-out-of-date
nobody
None
5
2010-08-28
2008-03-03
Anonymous
No

I downloaded this morning the expect and tcl cvs head snapshot from activestate. The tcl built and installed just fine. When I build and attempt to compile the expect cvs head, though, I get:

cc -DPACKAGE_NAME=\"expect\" -DPACKAGE_TARNAME=\"expect\" -DPACKAGE_VERSION=\"5.
44.1.5\" -DPACKAGE_STRING=\"expect\ 5.44.1.5\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_H
EADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRIN
G_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_UNISTD_H=1
-DWORDS_BIGENDIAN=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_THREAD_ALLOC=1
-D_REENTRANT=1 -D_POSIX_PTHREAD_SEMANTICS=1 -D_THREAD_SAFE=1 -DTCL_THREADS=1 -D
_REENTRANT=1 -D_POSIX_PTHREAD_SEMANTICS=1 -DTCL_WIDE_INT_IS_LONG=1 -DUSE_TCL_STU
BS=1 -DHAVE_SYS_SELECT_H=1 -DHAVE_SYSMACROS_H=1 -DHAVE_VARARGS_H=1 -DHAVE_STROPT
S_H=1 -DHAVE_SYSCONF_H=1 -DHAVE_SYS_FCNTL_H=1 -DHAVE_SYS_PTEM_H=1 -DHAVE_STRREDI
R_H=1 -DRETSIGTYPE=void -DHAVE_SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_TZNAME
=1 -DHAVE_GMTIME_R=1 -DHAVE_LOCALTIME_R=1 -DHAVE_TIMEZONE_VAR=1 -DNO_UNION_WAIT=
1 -DSOLARIS=1 -DHAVE_MEMMOVE=1 -DHAVE_SYSCONF=1 -DHAVE_STRFTIME=1 -DHAVE_STRCHR=
1 -DHAVE_TIMEZONE=1 -DHAVE_SIGLONGJMP=1 -DHAVE_MEMCPY=1 -DWNOHANG_BACKUP_VALUE=6
4 -DSELECT_MASK_TYPE=fd_set -DREARM_SIG=1 -DHAVE_PTMX=1 -DHAVE_TCSETATTR=1 -DPOS
IX=1 -DHAVE_SGTTYB=1 -DHAVE_TERMIO=1 -DHAVE_TERMIOS=1 -DHAVE_TCGETS_OR_TCGETA_IN
_TERMIOS_H=1 -DHAVE_TIOCGWINSZ_IN_TERMIOS_H=1 -DSETPGRP_VOID=1 -DHAVE_SV_TIMEZON
E=1 -DHAVE_LONG_FILE_NAMES=1 -DTCL_DEBUGGER -DUSE_NON_CONST -DSCRIPTDIR=\"/proj
ects/sprs_lwv/tcl85/lib/expect5.44.1.5\" -DEXECSCRIPTDIR=\"/projects/sprs_lwv/tc
l85/lib/expect5.44.1.5\" -DSTTY_BIN=\"/bin/stty\" -DDFLT_STTY="\"sane\"" -I. -I"
.." -I"/vol/tclsrcsol/tcl85/tcl/generic" -I"/vol/tclsrcsol/tcl85/tcl/unix" -I"/p
rojects/sprs_lwv/tcl85/include" -xarch=v9 -KPIC -c `echo ../exp_tty.c` -o e
xp_tty.o
"/vol/tclsrcsol/tcl85/tcl/unix/tclUnixPort.h", line 112: warning: old-style decl
aration or incorrect type for: MODULE_SCOPE
"/vol/tclsrcsol/tcl85/tcl/unix/tclUnixPort.h", line 112: syntax error before or
at: int
cc: acomp failed for ../exp_tty.c
gmake: *** [exp_tty.o] Error 2

Is this a Tcl bug or an expect bug?

I am using a SPARC Solaris 9 system, and Sun's C compiler.

I configured both packages with options \"'--prefix=/projects/sprs_lwv/tcl85' '--enable-shared' '--enable
-symbols' '--enable-stubs' '--enable-64bit' 'CC=cc'\"

Discussion

  • Jeffrey Hobbs

    Jeffrey Hobbs - 2010-08-28
    • status: open --> closed-out-of-date
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks