#13 expect core dumps on a newbie script

closed-out-of-date
nobody
None
7
2003-02-19
2002-05-29
Danny Yoo
No

We're using 'expect' and 'cron' to automatically update
a web site every evening, and I've noticed that
'expect' coredumps after the script is done! I am
using expect-5.32.2.

Here's a stack trace of the situation:

###
[dyoo@tesuque production_pub]$ gdb expect
GNU gdb Red Hat Linux (5.1-1)
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public
License, and you are
welcome to change it and/or distribute copies of it
under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show
warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run autoupdate.sh
Starting program: /usr/bin/expect autoupdate.sh
Logging in.
spawn cvs -d
:pserver:anonymous@cvs.gmod.sourceforge.net:/cvsroot/gmod
login
Logging in to
:pserver:anonymous@cvs.gmod.sourceforge.net:2401/cvsroot/gmod
CVS password: Now updating repository.
spawn cvs -d
:pserver:anonymous@cvs.gmod.sourceforge.net:/cvsroot/gmod
update -d
Now regenerating pub.
spawn /opt3/jakarta-ant/dist/bin/ant restart
All done!(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x40030e8a in expStateCheck () from /usr/lib/libexpect.so.0
(gdb) bt
#0 0x40030e8a in expStateCheck () from
/usr/lib/libexpect.so.0
#1 0x400310dc in exp_close () from /usr/lib/libexpect.so.0
#2 0x400464fa in exp_close_all () from
/usr/lib/libexpect.so.0
#3 0x4003e6d1 in exp_exit_handlers () from
/usr/lib/libexpect.so.0
#4 0x40087ded in Tcl_Finalize () from /usr/lib/libtcl.so.0
#5 0x40087c01 in Tcl_Exit () from /usr/lib/libtcl.so.0
#6 0x40033e00 in Exp_ExitCmd () from
/usr/lib/libexpect.so.0
#7 0x4006e1a0 in TclInvokeStringCommand () from
/usr/lib/libtcl.so.0
#8 0x400a51cd in EvalObjv () from /usr/lib/libtcl.so.0
#9 0x400a589b in Tcl_EvalEx () from /usr/lib/libtcl.so.0
#10 0x4009ce50 in Tcl_EvalFile () from /usr/lib/libtcl.so.0
#11 0x4003f8c8 in exp_interpret_cmdfilename () from
/usr/lib/libexpect.so.0
#12 0x08048a58 in main ()
#13 0x40118647 in __libc_start_main (main=0x8048980
<main>, argc=2,
ubp_av=0xbfffdf04, init=0x8048760 <_init>,
fini=0x8048ab0 <_fini>,
rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbfffdefc)
at ../sysdeps/generic/libc-start.c:129
###

I will also include a copy of my script.

Discussion

  • Danny Yoo

    Danny Yoo - 2002-05-29

    cvs auto updating expect script that provokes crash

     
  • Danny Yoo

    Danny Yoo - 2002-11-01
    • priority: 5 --> 7
     
  • Andreas Kupries

    Andreas Kupries - 2002-11-01

    Logged In: YES
    user_id=75003

    Questions:
    * Is this problem reproducible when using the newest release
    of expect, 5.38 ?
    * What version of Tcl is used ? The newest stable release is
    8.4.1. Is the problem reproducible with that version of tcl too ?

     
  • Jeffrey Hobbs

    Jeffrey Hobbs - 2003-02-19
    • status: open --> closed
     
  • Jeffrey Hobbs

    Jeffrey Hobbs - 2003-02-19
    • status: closed --> closed-out-of-date
     
  • Jeffrey Hobbs

    Jeffrey Hobbs - 2003-02-19

    Logged In: YES
    user_id=72656

    assuming out-of-date due to no response.

     

Log in to post a comment.