In the Debian bug report #342684  it has been pointed out, that expat 2.0.1 shipped too old libtool scripts to support GNU/k*BSD. Please update them with the next release.
This could be a duplicate of item 1983953.
According to the Debian bug report, it might be sufficient to update only config.sub and config.guess.
If libtool needs to be updated as well (currently at 1.5.22), it seems there is a big version jump from 1.5.x to 2.2.x necessary if going to the most recent version. Any opinions on that?
We updated to the latest version of the 1.x release of libtool. The following files have been updated: config.sub, config.guess, conftools/ltmain.sh, conftools/libtool.m4. Then configure has been recreated.
I have already updated config.sub/guess to the most recent available version.
I suggest we then use ltmain.sh and libtool.m4 from libtool 1.5.26 for the next Expat release.
This is really imperative to fix (and I saw I patch had been submitted), because I had to downgrade libtool to 1.5.x to even compile the latest CVS version. In my experience with Linux, you need to upgrade at least every two years or less and less software works, so it's going not going to be long before the vast majority of users find getting the latest secure version a major nuisance or perhaps even an impossibility.
I spent some time trying to update to the latest libtool, and that's certainly a losing battle.
Hopefully someone with enough autohell-fu will provide a patch.
Modified build system to use autoreconf -fvi instead of buildconf.sh.
(buildconf.sh now just calls autoreconf)
Fixed since 2.1.0, closing.
Log in to post a comment.