#289 Update to libtool 1.5

Feature Request
closed-fixed
5
2006-01-13
2003-12-20
Anonymous
No

Please update the libtool included with expat to version 1.5
(stable). It makes building on platforms such as Cygwin
easier, as well as easing integration when combining expat
with other modern projects.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    This is easy to do, manually:

    1) make distclean
    2) Either libtoolize or update config.guess, config.sub, ltmain.sh files
    within conftools. Manually copy the latest libtool.m4 into conftools.
    3) autoheader && autoconf.

     
  • Nobody/Anonymous

    Logged In: NO

    bah, i just wasted a day or so because the libtool included
    in the expat 1.95.7 is too old and does not work on current
    mingw (i have 3.1.0)
    it produces unusable libraries, and programs linked against
    them crash in funny ways (gdb does not give a useful
    backtrace...)

    please release a new version with libtool 1.5, that should
    work a whole lot better (i have 1.4e which seems to be a
    alpha or beta of 1.5)

     
  • Fred L. Drake, Jr.

    Logged In: YES
    user_id=3066

    Greg, can you try to get to this soon? I'd like to release
    a new version of Expat this month.

     
  • Fred L. Drake, Jr.

    • priority: 5 --> 7
     
  • Christian Ehrlicher

    Logged In: YES
    user_id=798735

    Is the old libtool also responsible for this output when I
    want to link against libexpat?
    libtool: link: warning: `/usr/lib/libexpat.la' seems to be moved

    I've build from src.rpm. And now in /usr/lib/libexpat.la the
    libdir-path is /var/tmp/expat-buildroot/usr/lib which causes
    this error. It would be fine if this would go away with the
    'new' libtool

     
  • Fred L. Drake, Jr.

    • priority: 7 --> 5
     
  • Fred L. Drake, Jr.

    • assigned_to: gstein --> fdrake
     
  • Fred L. Drake, Jr.

    Logged In: YES
    user_id=3066

    I'm planning to construct the next release using libtool
    1.5.10, so this problem should be solved with Expat
    1.95.9.

     
  • Karl Waclawek

    Karl Waclawek - 2006-01-13

    Logged In: YES
    user_id=290026

    The Expat 2.0 tarball was made using libtool 1.5.22.
    Closing the issue.

     
  • Karl Waclawek

    Karl Waclawek - 2006-01-13
    • status: open --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks