Sorry for my obtuseness. 

I found out, in a clearer moment, that I can open the standard oXygen under Java 7 with

export JAVA_HOME=`/usr/libexec/java_home -v 1.7`
cd /Applications/oxygen/
./oxygenMac.sh

as well, and eXist-db can be accessed again. I guess it then does not use the bundled JVM? However, double-clicking the version which bundles Java 7 is nicer.

Thank everybody for their patience!

Jens

On 1 May 2014 at 13:19:29, Joe Wicentowski (joewiz@gmail.com) wrote:

Ah, I forgot: to get this version, you need to read the fine print at
http://www.oxygenxml.com/download_oxygenxml_editor.html:

"If you have OS X 10.7, 10.8 or 10.9 you can use the OS X 10.7 and
later download which bundles Java SE 7. In this case Java is no longer
required to be installed separately."

The direct download link to this version in the fine print is
http://www.oxygenxml.com/InstData/Editor/MacOSX/VM/oxygen.tar.gz (145
MB) as opposed to
http://www.oxygenxml.com/InstData/Editor/MacOSX/oxygen.zip (118 MB).

Joe

On Thu, May 1, 2014 at 7:13 AM, Joe Wicentowski <joewiz@gmail.com> wrote:
> Hi Jens,
>
> This might be a question for the oXygen forums or support line, but
> oXygen 15.2 bundles Java 7 for Mac OS X 10.7+: see
> http://www.oxygenxml.com/forum/topic10185.html and
> http://www.oxygenxml.com/whatisnew15.2.html (under "Bundled Java 7 JRE
> in the Mac OS X Installation Kit").
>
> Joe
>
> On Thu, May 1, 2014 at 6:57 AM, Jens Østergaard Petersen
> <oesterg@gmail.com> wrote:
>> Hi Joe and Dannes,
>>
>> Yes, I did restart, but Dannes is right: my oXygen is running on the Mac OS
>> default java.runtime.version 1.6.0_65-b14-462-11M4609 (which I believe you
>> are not supposed to fiddle with).
>>
>> Perhaps it is because I am exceptionally jet-lagged, but I do not find
>> instructions about how to set oXygen to run on Java 7 on Mac OS X. The old
>> instructions at <http://www.oxygenxml.com/forum/topic6996.html> do not help,
>> since I don't see how "to move Java 7 at the top of the list in Java
>> Preferences" - that would be the Java Control Panel, I guess, but it only
>> knows of Java 7.
>>
>> Jens
>>
>> On 1 May 2014 at 12:23:40, Joe Wicentowski (joewiz@gmail.com) wrote:
>>
>> And did you restart oxygen if you updated the jars at an existing data
>> source?
>>
>> Sent from my iPhone
>>
>> On May 1, 2014, at 5:32 AM, Dmitriy Shabanov <shabanovd@gmail.com> wrote:
>>
>> Did you update eXist's jar at oXygen?
>>
>> On Thu, May 1, 2014 at 1:29 PM, Jens Østergaard Petersen <oesterg@gmail.com>
>> wrote:
>>>
>>> Hi,
>>>
>>> Does this mean that one cannot access eXist-db from oXygen?
>>>
>>> Could not instantiate: ro.sync.db.nxd.exist.ExistSession due to:
>>> java.lang.UnsupportedClassVersionError: org/exist/xquery/XPathException :
>>> Unsupported major.minor version 51.0
>>>
>>> is the error I get.
>>
>>
>>
>> --
>> Dmitriy Shabanov
>>
>> ------------------------------------------------------------------------------
>> "Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
>> Instantly run your Selenium tests across 300+ browser/OS combos. Get
>> unparalleled scalability from the best Selenium testing platform available.
>> Simple to use. Nothing to install. Get started now for free."
>> http://p.sf.net/sfu/SauceLabs
>>
>> _______________________________________________
>> Exist-development mailing list
>> Exist-development@lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/exist-development