DAOCSkilla error - access violation ...

2004-01-19
2004-01-20
  • nope no way

    nope no way - 2004-01-19

    Ok, here's what happens.  I fire up DAOCSkilla, then start DAOC.  Excalibur comes up fine, shows map & mobs/etc.  Regular activity (making items, zoning, etc) works fine, but when I target a mob or a player I get this error message:

    "Access violation at address 00409C99 in module 'daocskilla.exe'.  Read of address 00000000."

    What I've done so far:
    1) Remove and redownload the program
    2) Rip out the .ini file and let the program rebuild it
    3) Had a friend send me his .ini and inserted that into the program folder
    4) Reinstall WinPCap
    5) Reinstall DAOC (hey, it was worth a shot)

    For all intents and purposes nothing should be different about today compared to when it was working fine yesterday.

    Some other info, unsure if it's relevant.
    1) Using OpenGL 1.3 with GLUT
    2) Windows XP with all service packs/updates/etc
    3) Tried this with SI and TOA clients
    4) Happens with or without Excalibur window up

    Has anyone run across this?

     
    • Anonymous - 2004-01-19

      I've never head of that happening, but I'll look into it.  This is v1.78 I assume?  Thanks for the good description of the error too!

       
    • Rich

      Rich - 2004-01-19

      Finnally someone that has tried to help themself before coming here =)

      I am assuming you have rebooted after installing WinPCap....

      This is how I currently got my setup done, just so I could avoid all errors possible. Dropped packet.dll in my system 32 directory, dropped glut inside my daocskilla directory along with packet.dll again.

      Rebooted. I really dont know what could be wrong, I am not a developer on this project, just got alot of experiance using it.

      I really dont have any suggestions, other then trying to reinstall nic card drivers but i very highly doubt that would be the problem, since you can get on the net ect... Might have to just way until T can reply.

       
    • Rich

      Rich - 2004-01-19

      Gah T highjacked my reply =/ Just ignore my post hehe he replied before I did, as i was typing it out =)

       
    • nope no way

      nope no way - 2004-01-19

      Hey, thanks for the responses.  As for my original post, let's just say I'm a huge fan of this document: http://www.linuxmafia.com/faq/Essays/smart-questions.html

      Hehe :)

      Ok anyways here's some more information.  When I posted this last night I was in a hurry to get out to work (yeah I'm an overnighter!) and unintentionally left a few things out.

      1) DAOCSkilla is actually reporting OpenGL 1.4.1, not 1.3.
      2) Yes, this is v1.78.
      3) I have it configured the same way as you do, packet.dll file in system32 directory along with glut.dll and packet.dll in daocskilla directory.
      4) The drivers I am using for my network adapter are the ones that came off the Windows XP CD - I will go to SiS's website and download whatever they have available for kicks though.

      If I let the program sit long enough without acknowledging the error message, the Windows XP error reporting service will step in and say that Network Utility for Dark Age Of Camelot has encountered a problem.  This is the error signature:

      AppName: daocskilla.exe     AppVer: 1.78.0.0     ModName: daocskilla.exe
      ModVer: 1.78.0.0     Offset: 00009c99

      And, consistent with the original error message, the contents at that particular offset in the stack dump are 00000000.

      If you need/want anything else outta the stack dump lemme know.  I can't copy/paste the contents but if you know any other ways (short of taking screenshots) I'll grab whatever you need.

      Hope that helps, I'll be tinkering with this for awhile so if I come up with anything else I'll let you know.

       
    • Anonymous - 2004-01-19

      This seeeeeems to be a problem that comes from the ChatLog parser trying to parse the name of your target  (specifically removing "the" if it exists).  This is very odd if that is the case.  Is this an English version?  What chat text comes out whe you select something (specifically the "You target [xxx]" line and the "You examine ...." line)?  It appears that one of these is throwing off the parser.

       
    • nope no way

      nope no way - 2004-01-19

      I thought about that too.

      Here's a snippet from the realchat.log file:

      [07.27.02] You target [standifer2]
      [07.27.02] You examine standifer2.  He is a member of the Mercenary class in your realm.

      And just now I went in without DAOCSkilla running and had the game log the same information:

      [07:52:21] You target [standifer2]
      [07:52:21] You examine standifer2.  He is a member of the Mercenary class in your realm.

      chat.log and realchat.log match up.

      Then I went to Goth Harbor and conned a mob there, this is what showed up in realchat.log:

      [07.57.42] XI: New Target: "large dragonfly" Level: 1 Health: 100%
      [07.57.42] XI: Local Player: "standifer2" Level: 22 Health: 100% Endurance: 100% Mana: 0%
      [07.57.43] You target [the large dragonfly]
      [07.57.43] You examine the large dragonfly.  It is neutral towards you.

      And in chat.log:

      [08:05:23] You target [the large dragonfly]
      [08:05:23] You examine the large dragonfly.  It is neutral towards you.

      From that angle the parser appears to be working properly - however it's adding extra information about the target, and I wonder if maybe that has something to do with it.  the Is there any way to disable that feature?  Looked all over DAOCSkilla and didn't see anything obvious. :)

       
      • Anonymous - 2004-01-20

        No there's no way to disable the XI at this time, the option is waiting on UI design (although now that I think about it, I dunno why I don't have it in the INI, but that's another story).  Also, to verify, these are the lines that occured near the access violation?  Just odd because they look like the parser shouldn't have a problem with them.

         
    • nope no way

      nope no way - 2004-01-19

      By the way, yes this is the US version of the game.

       
    • nope no way

      nope no way - 2004-01-20

      I figured it out - and I posted the answer to the problem almost 24 hours ago!  It's the time separator character - notice in the realchat.log snippets I've got the time units are NOT separated by colons ... that's because I'm an uber geek and I like to separate hours/minutes/seconds and area codes/exchanges with periods instead.

      I think this is what caused the problem:

      Due to one of the classes I'm taking right now I had to reconfigure my computer for a dual-boot setup, which made reinstalling Windows a necessity.  When I got Windows XP back up a friend showed me where I could get DAOCSkilla and during the course of checking that out I just forgot to reset all the little settings in Windows the way I wanted to ... then when I finally did get around to doing it, that's when this mess started.  I'm not sure why the program is so particular about it, unless it's somehow geared to expect a colon and gets confused when it receives a period instead ...

      I closed the program, went into the Windows regional settings and adjusted the proper setting, started the program back up, and everything now works as it should.  I looked over this thread probably 20 times over the last 36 hours because it was bugging me and it didn't hit me until just now.

      So with that, I'm going to call total PEBKAC on this problem - and throw this in as a suggestion for a future update to the program.  Thanks helping me solve my own problem! heheh

       
      • Anonymous - 2004-01-20

        Holy crap, aren't you the smartie!  That's so bizzare, but I'll make sure it works for the next version.

         
      • Anonymous - 2004-01-20

        Ahhh I found the problem.  The problem wasn't so much that it wanted colons as it was with your substition.  When you con a mob, the old code looks for the first period then backtracks to find the mob name.  Of course, when the first period is in the time, this screws everything up.  I'll go through and fix that up, as well as any other places I use the same thing.  Good thing you spotted this, because I would have had one hell of a time figuring it out.

         
        • nope no way

          nope no way - 2004-01-20

          woot!  If I break anything else I'll let you know. :D

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks