#10 compile failure with GCC 3

open
nobody
None
5
2003-03-31
2003-03-31
Anonymous
No

Hi:

Just thought I'd let you know. Recently I upgraded to
Slackware 9.0, which is based on GCC 3.2.2, as opposed
to version 8.1, which was based on 2.95.3. My system
comes equipped with all necessary libraries for
compilation except glut, which I downloaded and
compiled version 3.7 for use here. I had to copy the
header files from include/GL to the proper directory
and copy the library itself to a location listed in
ld.so.conf, then run ldconfig. Everything goes
smoothly until the final linking of object files, which
produced for the first time several unresolved symbols.
Knowing that I had successfully compiled Excalibur
before on Slackware 8.1, I copied the old glut library
off of one of my other boxes which will stay with
Slackware 8.1 onto my new box and re-ran make.
Everything worked perfectly. Hence, the problem seems
to lie somewhere in the final linking process of
excalibur's make if libGlut is compiled with GCC 3.
Here are my system specs:

CPU: AMD Athlon 2400+
Mem: 1GB PC2700 DDR
OS: Slackware 9.0 (libGLUT compiled on Slackware 8.1)
Mobo: Asus A7N8X Dlx with the latest BIOS

Now everything is kosher :)

Thanks for providing an excellent product!!

You can reach me if you need more information at m dot
mohr at la poste dot net . (remove all spaces and
replace dot and at placeholders with their real values).

Discussion


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks