#12 Cygwin CURL problem

closed
Bodo
None
5
2014-08-26
2009-11-17
Anonymous
No

Trying to install the latest version of esniper in cygwin results in a failure at the configure step, reporting :
cheding for curl-config... curl-config
checking for curl_easy_setopt... no
configure: error:cURL 7.1.1. or newer required...

However curl --V reports curl version 7.16.3 installed. I checked the cygwin install and there's curl-dev installed as well.

This started with esniper 2-19, but I got around that by using the 2-18 configure file. However this now causes the current version to crash.

I've had a brief dig in the configure file, and the curl checks have changed, but I'm not clued up enough to work out what the actual issue is easily.

Any advice??

Thanks,

Robin

Discussion

  • Bodo

    Bodo - 2009-11-21
    • assigned_to: nobody --> bomm
     
  • Bodo

    Bodo - 2009-11-21

    The script "configure" is generated from "configure.in"
    Message "cURL 7.1.1. or newer required..." is hard coded in configure.in. It is printed if the function curl_easy_setopt is not found.
    The original check and message was added in 2007 because functions curl_easy_* were introduced in curl 7.1.1.
    The check for curl functions was modified in 2008, I think for version 2.18.1. Now some curl-config calls are used to get the correct compiler and linker flags, but basically it should do the same.
    Maybe this does not work with cygwin?
    If there are other changes in the configure script, this may be a result of different autoconf/automake versions.

    Unfortunately I don't have a system with cygwin available.
    Please run both the current configure script and the script from version 2.18 and attach the resulting config.log files.

     
  • Anonymous - 2010-06-02
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks