SSL Problem

Help
2005-02-09
2013-05-13
  • Nils Rottgardt

    Nils Rottgardt - 2005-02-09

    Hi.

    The program works in getting information about an auction, but I have problems in bidding. Everytime I get the following logentrys? I do not know where to set the SSL path. But SSL works... ??? Have anyone an explanation?

    Augur

    *** 2005-02-09 11:58:36.305421 https://signin.ebay.com/ws/eBayISAPI.dll?SignIn

    *** 2005-02-09 11:58:36.677178 problem with the SSL CA cert (path? access rights?)

    *** 2005-02-09 11:58:36.677283 error setting certificate verify locations

     
    • Anonymous - 2005-02-09

      It looks like libcurl can't find you certs file.  See http://curl.haxx.se/docs/faq.html#4.12 and http://curl.haxx.se/docs/sslcerts.html for details.

       
    • Nils Rottgardt

      Nils Rottgardt - 2005-02-09

      Hi, I disable the function to verify the peer. Now it is a little bit less save. But it functions. THX

      In http.c in the initCurlStuff(void) function

      curl_easy_setopt(easyhandle, CURLOPT_SSL_VERIFYPEER, FALSE);

       
      • Anonymous - 2005-02-09

        While that works, you should have been able to get verification to work.  Perhaps there were permission problems on the path to the certificates, or they weren't installed, or ???

         
    • Bucko

      Bucko - 2005-07-04

      I had the same error (on linux), turned out to be permission of file

      /usr/share/ssl/certs/ca-bundle.crt

       
    • Katit Software Consulting Servi

      I used Win32 installer and get this now:

      *** 2007-07-24 18:52:55.937750 https://signin.ebay.com/ws/eBayISAPI.dll?SignIn

      *** 2007-07-24 18:52:56.014750 problem with the SSL CA cert (path? access rights?)

      *** 2007-07-24 18:52:56.014750 error setting certificate verify locations:
        CAfile: /usr/share/curl/curl-ca-bundle.crt
        CApath: none

      How do I fix that?
      c:/usr/share/curl/curl-ca-bundle.crt does have certificate

       
    • Anonymous - 2008-01-06

      I had the same error when I tried to run esniper on Ubuntu 7.10

      Easily fixed by making a link like this :-

      sudo ln -s /usr/share/apps/kssl/ca-bundle.crt /etc/ssl/certs/ca-certificates.crt

      Hope that helps

      Thanks for esniper guys , it rocks!
      Mark Waters

       
    • Al_C

      Al_C - 2009-02-09

      Hi,

      Could an fglrx installation on my Slackware 12.2 have messed up my certs?

      esniper 2.19.0 works excellently on a Slackware 11.0 box

      And I thought I also had it working for a while on a Slackware 12.2 box

      But now on the 12.2 it's unable to verify certificate. The esniper reported error is enclosed at bottom.

      I made the same ln -s link as the above post. yes I do have the file:

      /usr/share/apps/kssl/ca-bundle.crt

      /etc/profile.d/curl-env.sh

      the above during system bootup is sourced by /etc/profile which results in the next env var being set system wide

      root@P5Q:~# env | grep CU
      CURL_CA_BUNDLE=/etc/ssl/certs/ca-certificates.crt

      whereby that is the link to the above (under /usr/share) file

      curl https://signin.eb<snipped>om/ws/eBayISAPI.dll?SignIn

      That command (less the <snipped> portion) returns the html markup to STDOUT

      So, I thus know that it's after username and password are entered is where my problem happens.

      Firefox 3.06 logs on just fine to my eb<snipped>ay (less the <snipped>).

      Same error also occurs when run esniper as root. (not a permissions issue).

      What do I need to do here to get it working?

      Cannot connect to URL : Peer certificate cannot be authenticated with known CA certificates: SSL certificate problem, verify that the CA cert is OK. Details:
      error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

       
    • Al_C

      Al_C - 2009-02-27

      Curl recently stopped shipping a cert bundle with curl.

      http://curl.haxx.se/docs/faq.html#Why_don_t_you_update_ca_bundle_c

      Slackware 12.2 shipped with said curl and with no cert bundle for curl.

      I got it fixed for me.  One way to fix this in Slackware 12.2 is here:

      http://www.linuxquestions.org/questions/slackware-14/openssl-ssl-error-code-14090086-verify-the-ca-cert-is-ok-certificate-verify-failed-703523/#post3459043

      Thank you oh so much for esniper!!!  It rocks!!

      --
      Alan.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks