Help with running esniper

  • Nitin

    Nitin - 2008-04-30


    I downloaded esniper and untarred it on linux. I cannot see any esniper executable. There is a snipe executable in ./frontends directory. On the esniper website I got documentation for esniper command but not snipe executable. The command line options for esniper are not valid for snipe.

    Does anyone can help me here? From where I can get esniper executable? How to use snipe?

    Thanks and Regards

    • Anonymous - 2008-04-30

      You need to build it first.  Run the configure script, make and make install.  Here's the steps:

      make install

      You might need to be root to install, depends on where you are putting it.  The executable installed is esniper.

      snipe is a shell script that helps you run esniper by allowing you to refer to a running esniper by the name of the auction file it is using.  You do not need to use snipe if you don't want to.

    • Nitin

      Nitin - 2008-05-01

      Thanks Scott, That was very helpful.

      But I am getting following error on configure -"configure: error: cURL 7.1.1 or newer required"
      And when I do curl --version, I get "curl 7.16.3 (i686-pc-cygwin) libcurl/7.16.3 OpenSSL/0.9.8g zlib/1.2.3 libssh2/0.15-CVS"

      Now with current version of curl as 7.16.3, and esniper wanting 7.1.1 or more, I am not sure what to do.

      Any help would be great.


      • upD8R

        upD8R - 2008-05-01

        I assume you need libcurl and not the precompiled version if curl. Just guessing, though ...

      • Anonymous - 2008-05-01

        Do you have two versions of curl installed?  Is it possible that you are using a different path when running configure vs. when you tried curl-config on the command line?

        If that doesn't do it, I looked through configure and noticed one potential issue.  Edit configure and go to line 2900.  You should see:


        You are in the right spot.  Add another line:


        Then try running configure again.

    • Nitin

      Nitin - 2008-05-02

      Thanks Scott,

      I checked its only one version of curl and I tried your suggestion but it didn't worked.

      I fixed it basically by forcing script to execute. I did the following:

      Added this line
      Now the if loop check was avoided and it worked.

      esniper.exe is created but I haven't tested it.

      I don't know what are the implications of this, but I just want to use esniper.

      Thanks for your help, I will keep you posted if I get any weired behavior of esniper.

    • Nitin

      Nitin - 2008-05-02

      Ok I suspected, there might be some problems with esniper (when I forced it to build)

      On running esniper I get the following error
      Auction xxxxxx: Cannot connect to URL https://signin.ebay.9: couldn't connect to server: couldn't connect to host

      My internet connection is fine, in-fact I checked this URL, it seems to be non-existent. Can I change this in some config file?

      • Anonymous - 2008-05-02

        Can you turn debug on and send me the log file?  Use the line debug=true somewhere in an auction file or config file (default config file is $HOME/.esniper).  The log file will be esniper.<auction number>.log

        Did you try my suggestion for the configure script?

    • Anonymous - 2008-05-02

      BTW, my guess is that there are two versions of libCurl installed.  You've forced it to build with the newer version of libcurl, but the library that is loaded at runtime is the old version.

    • Nitin

      Nitin - 2008-05-04

      Scott, thanks again. I figured out, I gave the following information in config.txt
      historyHost =
      prebidHost =
      bidHost =
      loginHost =
      myeBayHost =
      and it worked.

      Let me know if you still want me to send you any logs etc. Thanks again for your help. I checked again, I have only one version of lib curl. Also, I have placed the libcurl path (>7.1.1) right in the front of PATH variable.

      • Anonymous - 2008-05-05

        Strange, you shouldn't need to do this, as these are the defaults.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks