CA Certificate Error - Solved

Help
bipperred
2012-10-21
2013-06-25
  • bipperred

    bipperred - 2012-10-21

    Hello,

    I have tried to use esniper in the past, but always had problems with CA Certificate errors. I tried the suggestion of downloading a new certifcate, or downgrading my version of curl/openssl but nothing worked.

    I have now found a solution, as detailed here : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624005

    Uninstalling libcurl4-cares-dev, libcurl3-cares, and then installing libcurl4-gnutls-dev and recompiling worked for me.

    So :
    sudo apt-get remove  libcurl4-cares-dev
    sudo apt-get remove  libcurl3-cares

    ( I also remove sudo libcurl4-openssl-dev, but I am not sure this is required)

    sudo apt-get install  libcurl4-gnutls-dev

    and then in the untarred ensiper 2.27 folder
    ./configure
    sudo make install

    Thanks to the original posted in the Link.

     
  • Camden Lindsay

    Camden Lindsay - 2013-04-25

    A different curl/ssl related issue

    Apparently there is some issue with openssl strict implementation of certificate standards, or something similar. 
    curl can be built with openssl or gnutls.

    On my gentoo box I had to rebuild curl to use gnutls instead of openssl, and the intermittent problems went away.

    More details here:
    http://forums.gentoo.org/viewtopic-p-7297026.html#7297026

     
  • Tony Hammond

    Tony Hammond - 2013-06-25

    I had similar problems on ubuntu 12 after compling the source for the latest esniper from sourceforge. Thanks.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks