FieldTrip

Help
2012-06-15
2013-02-26
  • Lisa Tengstrand

    Lisa Tengstrand - 2012-06-15

    I'm having trouble with getting this warning message when having started up ep from the matlab prompt:

    Warning: You appear to be using the version of Fieldtrip that comes with EEGlab (in its external directory).
    It is recommended that you delete it and download the current version of FieldTrip.
    See tutorial file for details.

    I have downloaded and added the latest version of FieldTrip, deleted the old one, updated the path and cache but I still get the same warning message when starting ep.. Does anyone know how to solve this?

     
  • Joe Dien

    Joe Dien - 2012-06-16

    Did you also delete the version of FieldTrip that is located in the external directory of EEGlab?

     
  • Joe Dien

    Joe Dien - 2012-06-16

    In order to be helpful, I'm revising the warning text to be clearer in the next update:

    Warning: You appear to be using the version of Fieldtrip that comes with EEGlab (in its external directory).
    If you rely on it alone, it will tend to be an obsolete version, with unpatched bugs causing problems.
    If you have both a current version of FieldTrip installed and the older version that comes with EEGlab, then they tend to conflict and cause problems.
    It is recommended that you delete EEGlab''s copy and instead rely on just having the most recent version of FieldTrip installed separately.
    See tutorial file for details.

     
  • Lisa Tengstrand

    Lisa Tengstrand - 2012-06-19

    This is the mysterious thing, I have deleted the old file.. The new one is also included in the pathdef.m. Can this be due to something else? Do I need to place the (new) file somewhere else?

     
  • Lisa Tengstrand

    Lisa Tengstrand - 2012-06-19

    Just to be sure, I downloaded an even newer version of FieldTrip (20120618) and replaced the previous version (20120613) with the newer one. As a result of this, I get a new error message:

    Warning: You appear to be using the version of binica that comes with Fieldtrip (in its external directory).
    It is recommended that you delete it and download the current version of EEGlab.
    See tutorial file for details.

    I'm somewhat confused about this.. As I have understood it, eeglab comes with Fieldtrip so I guess this (20120618) version should be the most up to date?

     
  • Joe Dien

    Joe Dien - 2012-06-20

    Sorry to be confusing you.  What you need to do is:
    1) delete or deactivate the copy of EEGlab that is in the external folder of FieldTrip (note, you can do this just by removing FieldTrip from the path, just adding the root directory, then running ft_defaults)
    2) delete or deactivate the copy of FieldTrip that is in the external folder of EEGlab.

    Do not replace the copies that are in the external folders of either.

    Does this make sense now?

     
  • Lisa Tengstrand

    Lisa Tengstrand - 2012-06-20

    It does make sense now. Thank you!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks