Hi Willem,

Thanks for the great response...  I made the change to yaws_soap_lib, but that didn't change the result.  I also tried your code, and still have the same - it just hangs. 

I have basically done the same thing as you:

yaws_soap_lib:call(Wsdl, "FlightHistoryGetHistoryOperation", [], [#'p:FlightHistoryGetHistoryRequest'{
'Login'=#'p:Login'{'Guid'="*******************"},
'FlightHistoryGetHistoryInfo'=#'p:FlightHistoryGetHistoryInfo'{
'SpecificationFlight'=#'p:SpecificationFlight'{
'Airline'=#'p:Airline'{'AirlineCode'=AirlineCode},
'FlightNumber'=FlightNumber,
'SearchCodeshares'=true},
'SpecificationDateRange'=#'p:SpecificationDateRange'{'DepartureDateTimeMin'=DateMin, 'DepartureDateTimeMax'=DateMax}
}
}]).

Regards,

Andrew

On Mon, Jun 15, 2009 at 9:39 PM, Willem de Jong <w.a.de.jong@gmail.com> wrote:
Hello Andrew,
 
I didn't look into the first thing, but the second problem appears to be related to the inets http module. When I tried it with ibrowse, it worked. Note that the yaws_soap_lib module uses ibrowse by default, but it is not part of the normal distribution, so you have to get it from somewhere.
 
You can put http in a verbose mode to get some debugging info (see the manual), but that didn't help me - I have no idea why it hangs on this.
 
While looking at this, I discovered a bug that is unrelated, but since it occurs with the WSDL you provided it might be good to be aware of this. When I tried the FlightHistoryGetRecordsOperation operation, I got an error message from yaws_soap_lib ("operation not found", something like that). This can be solved by replacing line 483.
 
The wrong version of the line is:
      searchPorts(BindingName, Tail)
The right version is:
      searchPorts(BindingName, Tail, Acc)

Sorry for that...
 
I am attaching a small test-program.  Using ibrowse this works on my system (obviously it doesn't get a useful answer from the server, since I don't have an account, but it gets a proper soap error message).
 
Regards,
Willem
 

 
On Mon, Jun 15, 2009 at 2:52 PM, andrew mmc <andrewmmc@gmail.com> wrote:
Hello,

I am trying to use yaws_soap_lib to make a call to a Wsdl service - https://www.flightstats.com/developers/bin/download/Web+Services/WSDL/FlightHistoryService.wsdl

There are two main problems.  Firstly I cannot get yaws to read the WSDL directly from the URL - I had to download the file and read it in using initModel.  Why would this be?

Secondly, when I finally make the call to yaws_soap_lib:call, I do not get any errors, but it just hangs.  Using the example from the yaws documentation works fine.

Is there some way to find out what is going on? I have left it for longer than most timeouts and have yet to receive a result, or a failure.

Thanks in advance,

Andrew

------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Erlyaws-list mailing list
Erlyaws-list@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/erlyaws-list