Hi,

I've been playing around with yaws's websocket and using the documentation and the examples, I've managed to put together (mostly copy/paste) a working echo server with websocket:
https://github.com/f3r3nc/yaws-web-chat

However, I've bumped into some obstacles/confusions after that.

1) I've tried to start up the websocket in active mode. 
http://yaws.hyber.org/websockets.yaws suggest that in order to start websocket in active mode,  Out/1 should return  {websocket, OwnerPid, active}. However it didn't work even though ok was sent to OwnerPid by yaws.
yaws_api:websocket_setopts(WebSocket, [{active, true}]) was still needed.

2)  When using secure websocket ie: wss://localhost:7000/ the connection fails. 
Do I need to set up SSL in the configuration of the embedded yaws as well? 
Or something else?

Could you please let me know what's done wrong?
yaws-1.91.tar.gz from http://yaws.hyber.org/download/ is used.
Chrome 13.0.782.220 is used. (I saw in the archive that Chrome 14 has also some issues).

Not related to websocket, but I wanted to mention that compiling yaws from git doesn't work on OSX (Snow Leopard 10.6.6).
After autoconf ./configure would fail. It seemed that the EOL being in DOS format in the scripts was the problem.
After that ./configure worked but make failed.
Then dos2unix scritps/* helped for make to go further but failed again.
yaws_generated.erl didn't contain modue definition. (empty file)
after the rm src/yaws_generated.erl, make worked.

Getting directly the tar.gz, ./configure && make works just fine. 

Kind Regards,
Ferenc