I am quite new to erlang and yaws and this is my first post on this mailing list. I after playing around with the language and easy yaws features like ehtml and normal appmods I tried to write a yapp. I followed http://yaws.hyber.org/yapp_intro.yaws and https://github.com/davide/yawn/wiki to get it more or less running. It simply consists of an .app file and a simple test.erl/beam that just has a out/1.
Yaws starts without a problem and loads the yapp. When I run yaws in the interactive mode and call test:out(somehting) it works fine. When I surf the url (with browser or curl) I get an
"=ERROR REPORT==== Date ===
Yaws process died:..."
and nothing returned to the client. I have been trying around a couple of things, but I haven't found the problem yet.
I looked at stackoverflow, but people with the same problem where advised to poke around in the mailing list. Well, so here I am ;)

I believe the problem is in my .app file...
I hope you can help my. I added the content of the .app and my localhost-ssl.conf below.


marc@server:~$ cat /usr/lib/yaws/lib/api/ebin/api.app 
{application, api,
 [{description,"cloudia api as yapp"},
  {registered, []},
  {env, [

marc@server:~$ sudo cat /etc/yaws/conf.d/localhost-ssl.conf
<server localhost>
    port = 443
    listen =
    docroot = /usr/share/yaws
    arg_rewrite_mod = api
    #dir_listings = true
        keyfile = /etc/yaws/yaws-key.pem
        certfile = /etc/yaws/yaws-cert.pem
    yapp_server_id = edo