On Wed, 2004-07-28 at 06:01, Oded Arbel wrote:
Hi.

As mentioned in a previous email , I'm having some problem building etox from CVS. when trying to build, it starts linking etox_test , and then shows the following errors:

gcc: /usr/lib/libfreetype.a: No such file or directory
gcc: /usr/lib/libjpeg.a: No such file or directory

I have libjpeg62-devel-6b and libfreetype6-devel-2.1.8 installed, and the following files are found in the system:
/usr/lib/libjpeg.la
/usr/lib/libjpeg.so
/usr/lib/libfreetype.la
/usr/lib/libfreetype.so


You have to install the -static package of these libraries as well. I ran into the same problem a few days ago and that was the solution.

Wouter.

If I understand correctly, .la means its a libtool built library file, and I can clearly see that etox is being built and linked using libtool.
Other libraries build just fine.

I tried to trace the build process but didn't came with anything conclusive. can someone please comment on what might be my problem ?

Thx.

--
Oded

::..
"There is no reason anyone would want a computer in their home."
-- Ken Olson, president, chairman and founder of Digital Equipment Corp., 1977