#112 Strange Recording Error  Edit

open
recording (3)
5
2012-07-08
2003-04-10
Anonymous
No

I have the Audigy MP3+.

I'm using the CVS drivers from 4/9/2003.

All output etc. is working fine but I have no recording.

I've tried routing everything to Recording with no
luck. I can hear myself through my speakers and I can
change the mic level through aumix.

When I use the standard 'rec', it sits there resulting
in a 2092 byte wave file (which is probably just
headers) as it is always that size regardless of time,
sound etc.

strace gives me:
stat64("/usr/bin/sox", {st_mode=S_IFREG|0755,
st_size=232952, ...}) = 0
rt_sigprocmask(SIG_BLOCK, [INT CHLD], [], 8) = 0
fork() = 22127
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {0x8071f38, [], SA_RESTORER,
0x400869d8}, {SIG_DFL}, 8) = 0
wait4(-1,

and it just sits there. All recording programs hang or
fail. I have an onboard CMI8738 chip onboard but it's
disabled in the BIOS.

I've also tried routing Pcm to Recording and see if I
could record an ogg being played but no such luck. It
seems to be a more sinister problem than a simple route.

Anyone have any ideas? Thanks a bunch.

Regards,

--
Mike
mikew at ou-ou-gohnium dot com

SYSTEM INFO:
Linux shaggy 2.4.20 #4 Thu Dec 26 23:28:11 EST 2002
i686 unknown unknown GNU/Linux

lsmod
Module Size Used by Tainted: P
sound 58740 0 (unused)
emu10k1 66856 0
ac97_codec 10440 0 [emu10k1]
soundcore 3844 6 (autoclean) [sound
emu10k1]

NVdriver 1065216 10

Apr 9 20:46:50 shaggy kernel: Creative EMU10K1 PCI
Audio Driver, version 0.20a, 20:45:51 Apr 9 2003
Apr 9 20:46:50 shaggy kernel: PCI: Found IRQ 5 for
device 00:09.0
Apr 9 20:46:50 shaggy kernel: PCI: Sharing IRQ 5 with
00:04.2
Apr 9 20:46:50 shaggy kernel: PCI: Sharing IRQ 5 with
00:04.3
Apr 9 20:46:50 shaggy kernel: PCI: Sharing IRQ 5 with
00:0d.0
Apr 9 20:46:50 shaggy kernel: emu10k1: Audigy rev 3
model 0x0051 found, IO at 0xa000-0xa01f, IRQ 5
Apr 9 20:46:50 shaggy kernel: ac97_codec: AC97 codec,
id: 0x5452:0x4123 (TriTech TR A5)

As I see it is sharing some interrupts:

root@shaggy:# cat /proc/interrupts
CPU0
0: 42815904 XT-PIC timer
1: 4 XT-PIC keyboard
2: 0 XT-PIC cascade
5: 3614465 XT-PIC usb-uhci, usb-uhci,
eth0, Audigy
11: 25707620 XT-PIC nvidia
14: 372728 XT-PIC ide0
15: 227613 XT-PIC ide1
NMI: 0
LOC: 42815879
ERR: 7442
MIS: 0

lspci

00:05.0 Multimedia audio controller: C-Media
Electronics Inc CM8738 (rev 10)
00:09.0 Multimedia audio controller: Creative Labs SB
Audigy (rev 03)
00:09.1 Input device controller: Creative Labs SB
Audigy MIDI/Game port (rev 03)
00:09.2 FireWire (IEEE 1394): Creative Labs SB Audigy
FireWire Port
00:0d.0 Ethernet controller: Intel Corp. 82557/8/9
[Ethernet Pro 100] (rev 04)

Discussion


Anonymous

Cancel  Add attachments