Kiran - 2013-02-27

Hi everyone,

I am trying to activate jacoco plugin and found the command for that is
java -javaagent:jacocoagent.jar==,=

I gave the command in my cmd prompt and got this output.

java -javaagent:S:\maven.repo\org\jacoco\org.jacoco.agent\\org.jacoco.agent-\
Usage: java  class
           (to execute a class)
   or  java  -jar jarfile
           (to execute a jar file)
where options include:
    -d32          use a 32-bit data model if available
    -d64          use a 64-bit data model if available
    -server       to select the "server" VM
    -hotspot      is a synonym for the "server" VM 
                  The default VM is server.

    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A ; separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
                  set a system property
                  enable verbose output
    -version      print product version and exit
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -no-jre-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
                  enable assertions with specified granularity
                  disable assertions with specified granularity
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
                  load native agent library <libname>, e.g. -agentlib:hprof
                  see also, -agentlib:jdwp=help and -agentlib:hprof=help
                  load native agent library by full pathname
                  load Java programming language agent, see java.lang.instrument
                  show splash screen with specified image
See for more details.

This suggests that there is some problem in the syntax. But as you can see, syntax is correct. Can any one please let me know why is this happening and how to get around this..?