Question Marks instead of spaces in report?

2004-08-22
2013-05-09
  • Chad Woolley

    Chad Woolley - 2004-08-22

    Hi,

    In my report, I get question marks instead of spaces, like this:

    EMMA�Coverage�Report�(generated�Sun�Aug�22�00:01:26�MST�2004)

    I am running this under Linux.  I believe it was working correctly originally, and then started doing this for some unknown reason recently.  Any ideas?

    Thanks,
    Chad

     
    • Vlad Roubtsov

      Vlad Roubtsov - 2004-08-22

      The question marks are caused by non-breakable space characters (\u00A0). If they are not displayed correctly, it is a sign of your browser and/or HTTP server mangling or not respecting the original encoding of EMMA HTML report files.

      The default encoding is ISO-8859-1 and can be verified by checking the beginning of any .html file:

      <HTML><HEAD><META CONTENT="text/html; charset=ISO-8859-1" HTTP-EQUIV="Content-Type"/>...

       
    • Chad Woolley

      Chad Woolley - 2004-08-24

      Hmm - I'm running this through my homegrown Maven plugin (I never saw any activity on the other one).  That is probably the problem, but I don't know how to fix it...  Guess I'll live with it until I research.  Thanks for the response and tip. -- Chad

       
    • Vlad Roubtsov

      Vlad Roubtsov - 2004-08-24

      If you think this is a bug, maybe you could submit a Tracker issue and attach some sample .html files that reproduce the problem. Otherwise, you probably agree that I have nothing to go on: all of the previous instances of this problem have been caused by misconfigured browsers or HTTP servers.

      Regarding the Maven plugin, yes, I've been beating down on Dilum to communicate through the forums more and I have not been entirely successful. But at least we live in the same city, so we meet periodically and did see his demo of the EMMA Maven plugin report and it looked fine, no question marks.

       
    • Nobody/Anonymous

      I'm having this problem as well. Has anyone found any solutions?

       
      • Vlad Roubtsov

        Vlad Roubtsov - 2005-02-24

        The issue definitely has to do with your browser and char encoding for your platform. Check what it is and you will find the reason. The HTML encoding EMMA uses will be emitted in each HTML report file. Check its beginning:

        <HTML><HEAD><META CONTENT="text/html; charset=ISO-8859-1" ...

        and you will know what it is. Sorry, but I can't do this for you.

        Vlad Roubtsov.

         
    • Nobody/Anonymous

      Thanks for the reply.

      I actuallly just got the solution... it had to do with configuring my apache server. (For the record, my charset was ISO-8859-1).

      Anyway, here's a link that explains the solution:
      http://www.webservertalk.com/message882256.html

      Thanks for the great work! Emma works beautifully.

      Thanks,
      Ben

      p.s. after adding the horizontal bar patch, I think you should definitely make it a standard feature--basic users like good looking pages.

       
    • Nobody/Anonymous

      I have also had this problem. The default charset in the apache config as installed with the redhat rpm is UTF-8. Changing the setting in httpd.conf will fix the problem, as will renaming the .html file to .html.iso8859-1 (per type mappings in httpd.conf).

      This is likely a problem for users of redhat/apache web servers. I'm not sure if UTF-8 is the default for apache accross the board or just for redhat's distro. If defined, it will always take precedence over the definition in the html meta tag. I don't know of other ways to override the setting so that the default is not used. Maybe an apache expert can chime in here with an option.

      My only concern in changing the default encoding from unicode to western iso is that all current content served by this web server works with unicode. I'm not sure if it will all be compatible with western iso.

      John

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks