I tried to run xen-arm on pxa270 emulated on qemu by following this link

I am not able to get in to dom0 console at all.

This is what I ve done
1. I installed the cross compiler arm-unknown-linux-gnuabi-gcc. The Linux distro I use is Ubuntu 9.10.

2. I installed the qemu that came default with ubuntu 9.10 linux.

3. The I installed xen-pxa270-qemu from https://sourceforge.net/projects/embeddedxen.

4. To compile and run it, this is what I did
    a) I untarred the tarball and did a 'make all' inside the 'xen-pxa270-qemu' folder. Before firing the make command, I set the CROSS_COMPILE env variable to point to the cross compiler 'arm-unknown-linux-gnuabi-gcc'.

    b) Then after successful completion of make command, I followed the instructions in http://lists.xensource.com/archives/html/xen-arm/2009-05/msg00000.html

    c) When I run it in non-graphical mode with -nographic option in qemu-system-arm, the console outputs that xen image is getting loaded and linux image is getting loaded in dom0. After that nothing happens. I am not able to enter anything in the command console as it only displays 'Hit Ctrl 'A'  three times to enter in to xen mode'. When I hit Ctrl + 'A' three time it displays 'Hit Ctrl 'A'  three times to enter in to dom0'

   d) When I ran it, in Graphical mode I saw a black screen popping up and in the command window I see the message "map addr 0x8297e80". After that nothing happens. I am not able to see anything in the graphical screen too.

It would be extremely helpful if someone can tell me how to get in to dom0 console.