#9 emacs from CVS no longer builds on 10.2

closed
nobody
None
5
2005-03-06
2002-08-25
No

I checked out the project for the first time today, and
was unable to get it to compile correctly. It's also
hosed the porkrind.org Carbon version.

I built with --without-x and have attached my config.log

Here are the last lines from make:

cc -c -Demacs -DHAVE_CONFIG_H -I.
-I/Users/stevej/emacs/emacs/src -g -O nsselect.m
touch nswraps.m
cc -c -Demacs -DHAVE_CONFIG_H -I.
-I/Users/stevej/emacs/emacs/src -g -O nswraps.m
cc -c -Demacs -DHAVE_CONFIG_H -I.
-I/Users/stevej/emacs/emacs/src -g -O fontset.c
cc -c -Demacs -DHAVE_CONFIG_H -I.
-I/Users/stevej/emacs/emacs/src -g -O emacs.c
emacs.c: In function `main':
emacs.c:608: conflicting types for `sys_nerr'
/usr/include/stdio.h:265: previous declaration of
`sys_nerr'
make[1]: *** [emacs.o] Error 1
rm nswraps.m
make: *** [src] Error 2

regards,
steve

Discussion

  • steven m jenson

    steven m jenson - 2002-08-25

    Logged In: YES
    user_id=203476

    I was sure I had attached a file. I will again.

     
  • steven m jenson

    steven m jenson - 2002-08-25

    Logged In: YES
    user_id=203476

    What a horrible interface. Here you go.

     
  • steven m jenson

    steven m jenson - 2002-08-25

    output from config.log

     
  • Adrian Robert

    Adrian Robert - 2005-03-06
    • status: open --> closed
     
  • Adrian Robert

    Adrian Robert - 2005-03-06

    Logged In: YES
    user_id=146959

    Not sure if this is still relevant. As of 8.0-rc1 it builds
    now on Panther (don't use CVS, but download source from File
    releases), and has been reported to work on 10.1, so 10.2
    ought to work. Please re-report if not.

     

Log in to post a comment.