#18 i386 instead of noarch


<ache/apt/archives/emacrolibs-0.0.9-linux.deb ;echo RESULT=$?
dpkg: error processing /var/cache/apt/archives/emacrolibs-0.0.9-linux.deb (--install):
package architecture (i386) does not match system (powerpc)
Errors were encountered while processing:

Same problem with emacro


  • Bruce Ingalls

    Bruce Ingalls - 2003-10-24
    • labels: --> installation
    • milestone: --> minor
    • assigned_to: nobody --> bingalls
    • summary: i386 instead of independent --> i386 instead of noarch
    • priority: 5 --> 2
    • status: open --> pending-postponed
  • Bruce Ingalls

    Bruce Ingalls - 2003-10-24

    Logged In: YES

    Hm. EMacro installed fine, but you had problems with EMacro Libs,
    only? Strange, as these are packaged in the same way.
    Of course, you can use these separately, and you can always fall back
    to the tar.gz package.
    I use the EPM <url: http://www.easysw.com/ > packager v3.6 (latest
    stable) to create these packages. Nothing in any EMacro package is
    architecture specific. I will report this as a bug to the EPM maintainer.

    In the meantime, I posted an upgrade to EMacro v2.8.2 using EPM
    v3.7RC1. Let me know, if that helps.
    If you are interested, you can install EPM, and run the makepkg.sh
    script, yourself. The whole process, including learning curve, should
    take less than 15 min.

  • Bruce Ingalls

    Bruce Ingalls - 2003-10-30

    Logged In: YES

    Assuming that Debian supports <b>noarch</b>, this should be
    fixed as of v2.8.3. I don't have a debian ppc machine to
    test this with.

    Does debian use <b>independent</b> instead of <b>noarch</b>?

  • Bruce Ingalls

    Bruce Ingalls - 2003-10-30
    • status: pending-postponed --> closed-fixed

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks