accessing streamer from elphel 313 camera

  • Ron Vander Kooy

    Ron Vander Kooy - 2004-08-04

    I am using the Elphel NC313L camera with Ret Hat 8.0

    I have installed the Mplayer_LIVE_UCL.tgz with the '' script and the camera elphel_6.2.19A5.tar.gz with the './install_elphel' script.  I had downloaded the Linux kernel 2.4.22 and the Axis development board 82 software.  The CRIS compiler kit was installed prior to running the script.  Both install scripts have run without errors and I have updated the flash on the camera to 6.2.19A5 using the windows approach and Pcap.  When I boot the computer it still shows the old kernel, was the computer supposed to update to 2.4.22?  If so, how would I force the change?

    When I acess the camera with Mozilla ( I edit the image the way I want it to look.  I've been using 15 fps.  When I push the 'video streamers' button I get the 7 rtp/rtsp options.  The alexlp-rtsp shows a default IP address of and Port 20000.  Hitting start without changing the IP address starts a scrolling screen with fps, etc info and suggests URL rtsp:// which will not come up in Mozilla.  (rtsp not a registered protocol error)Changing the IP address to the computer or the camera IP results in a session error. 

    How do I access the stream coming from the camera?

    Any help or guidance would be greatly appreciated!  Thanks, Ron   

    • Sergey Khlutchin

      All right
      2.4.22 is kernel version in camera, kernel version in desktop computer may differ, it is unimportant.

      this URL is not supported by Mozilla and other browsers, this for mplayer, copy it to command line like this

      mplayer rtsp://
      mplayer rtsp://

    • Ron Vander Kooy

      Ron Vander Kooy - 2004-08-04

      I tried the commands you suggested both giving the errors shown below.  Is there a specific directory I should have installed mplayer from?  The directory /usr/local/etc/mplayer/ exists but no mplayer.conf file is in there. 

      Thanks for the help, Ron  

      [scwuser@localhost scwuser]$ mplayer rtsp://
      MPlayer 1.0pre5-3.2 (C) 2000-2004 MPlayer Team

      CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 997.0 MHz (Family: 6, Stepping: 10)
      Detected cache-line size is 32 bytes
      CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
      Compiled for x86 CPU with extensions: MMX MMX2 SSE

      Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
      Reading config file /home/scwuser/.mplayer/config
      Reading /home/scwuser/.mplayer/codecs.conf: Can't open '/home/scwuser/.mplayer/codecs.conf': No such file or directory
      Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
      Using built-in default codecs.conf.
      font: can't open file: /home/scwuser/.mplayer/font/font.desc
      font: can't open file: /usr/local/share/mplayer/font/font.desc
      Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
      Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
      Using usleep() timing
      Can't open input config file /home/scwuser/.mplayer/input.conf: No such file or directory
      Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
      Falling back on default (hardcoded) input config

      Playing rtsp://
      Connecting to server[]:7070 ...
      librtsp: server responds: 'RTSP/1.0 501 Not Implemented'
      rtsp_session: Not a Real server. Server type is 'unknown'.
      Not a Realmedia rtsp url. Trying standard rtsp protocol.
      RTSP support requires the "LIVE.COM Streaming Media" libraries!
      Unable to open URL: rtsp://

      Exiting... (End of file)
      [scwuser@localhost scwuser]$

      • Sergey Khlutchin

        Try 'make install' in directory with mplayer source files

    • Andrey Filippov

      Andrey Filippov - 2004-08-04


      You may disregard most of the messages from mplayer for now (missing cofiguartion files, fonts, the fact that it is not a "Real" stream, etc.)
      But you do need libraries. If you were installing the mplayer from this sourceforge project page, it installes in the local directory (with all the needed libraries) (usually ending with "/MPlayer-1.0pre4"). I suspect that you started the default version of mplayer on your system not the one you've built with "" support (it is based on "MPlayer-1.0pre4").
      To start the correct one - cd to the installation directory with the correct mplayer and use "./mplayer", not "mplayer"


    • Nobody/Anonymous

      >[scwuser@localhost scwuser]$ mplayer rtsp://
      MPlayer 1.0pre5-3.2 (C) 2000-2004 MPlayer Team

      Enter next
      which mplayer
      and look which mplayer started and from where.
      It mplayer started when you run program. After compiling mplayer 1.0 pre4(from sourceforge) you must run new compiled version as
      ./mplayer ...

      Next - you can check multicast
      All routers in local network answer to you. If not - add route

      route add netmask eth0
      On some OS you must add default gateway too
      (local interface or any router on local network)
      ifconfig eth0 - MULTICAST on your interface is on?

    • Ron Vander Kooy

      Ron Vander Kooy - 2004-08-06

      Thanks for your help and guidance, I have the camera up and working now.

      The 'route add -net netmask dev eth0' command is what fixed it. 

      Thanks again, Ron


Log in to post a comment.