I have two native EFI BIOS systems, one with CSM(Compatibility Support
Module) and another without it.  I run the elilo 3.6 version to boot
EFI-aware Linux(kernel 2.6.10) in the two BIOS. The elilo can boot to
EFI-aware Linux successfully in the EFI BIOS with CSM( I checked
/var/log/dmesg file showing the boot information: there is no e820 for the
memory description but the EFI version information, therefore EFI-aware
Linux).

But when I used elilo in the EFI BIOS without CSM, the elilo cannot boot
EFI-aware Linux but hanged before Linux kernel was loaded.

Setting elilo's option "verbose=5", the elilo gave back the following
information before the system hanged:
---------------------------------------------------------------------------------------------------------
ELILO boot
kernel is 'bzImage'
argument are 'root=/dev/hda1' acpi=ht resume=/dev/hda1 splash=silent'
kernel start: 0x100000 kernel_size:2097152
Using bzImage_loader loader
kernel loaded in [0x30000000100000-0x7A006200100000] entry=0x670061006D0049
final cmdline(0): BOOT_IMAGE=atapi0:\.\bzImage root=/dev/hda1 acpi=ht
resume=/dev/hda1 splash=silent
uninstalled vfat on
Acpi(PNP0A03,0)/Pci(1F|1)/Ata(Primary,Master)/HD(Part2,Sig000D9430)
boot params @0x1F52B9581DB40010

system.c(line 177):fill_boot_params()

alloc.c(line 163): free Pool @0x16001D582010 size=2113226482532982646

system.c(line 266): initrd->start_addr=0x0 initrd->pgcnt=0

alloc.c(line 110): alloc: allocated 4096 bytes
@[0x1D5830101D582010-0x1D53B04A1D539F76]

util.c(line 306):final get_memmap map_size=1314259996176

//the system hanged here
-----------------------------------------------------------------------------------------------------------

Besides, the elilo in the EFI BIOS without CSM showed a warning sentence
sometimes(not always):
    fileops.c(line 520): No devname schemes worked, using builtin.

And also, the system reset several times(just several times, not always)
automatically when the elilo hanged.

I am trying to trace the elilo debug information(-D flag) to find the
solution, but it seems somewhat non-efficient.