Ejbca 6.0.4 Build Failed

Help
merryo
2014-03-28
2014-04-02
  • merryo
    merryo
    2014-03-28

    I am getting error while building Ejbca 6.0.4 on Red Hat Enterprise Linux Server release 5 (Tikanga) machine. I am also using Mysql 5.6.15 Community server with jdk version 1.7.0_45.

    Please Help. Jboss server log and ant build log are attached in 2nd post.

     
    Last edit: merryo 2014-03-28
  • Are you using mor than one core and have enough memory?
    JBoss 7 will hang/freeze if you are for example running in a virtual machine with only one core, or too little memory.

     
  • merryo
    merryo
    2014-03-28

    I forrgot to mention that i am using jboss 7.1.1

     
  • merryo
    merryo
    2014-03-28

    Yes i am building this on a virtual machine with one core but allocated it 3GB RAM and jboss is running on standalone mode not on domain mode.

     
  • So that will not work, due to jboss requirements.

     
  • merryo
    merryo
    2014-03-28

    What do you suggest shall i increase the cores or RAM. Secondly I also raised the JAVA_OPTS to -Xms1303m -Xmx1303m rather -Xms64m -Xmx512m. Thirdly I tried this on Windows 7 machine running on Intel core i5 and the build was successful there. Any Idea

     
  • merryo
    merryo
    2014-04-02

    Well I change my vm processor settings and it worked. What i did is I changed 1 processor to 2 with 2 cores. Now just for my understanding I want to know few thigs if anyone can help.

    Why Jboss 7.1.1 was successful with EJBCA 4.0 professional with 1 processor and 1 core vm.
    Secondly i tried to find out jboss 7.1.1 running on multiple processors or cores but cannot find any material. Lastly I am still getting few warnings though my build and install of ejbca 6.0.4 was successfully done. Warning msgs shall be share in my next post.

     
  • What is "EJBCA 4.0 professional" and where did you find it?

     
  • We have had rather lengthy suppport issues with RedHat regarding JBoss EAP 6 (enterprise version of JBoss 7) to get confirmed that they do not support running on only 1 core.

     
  • merryo
    merryo
    2014-04-02

    Thanks for the update on jboss tomas. For Ejbca i was refering to EJBCA 4.0.16 which i tried last year with jboss 7.1.1 but it was on ubuntu 12.4.

     
  • 4.0.16 would never work on JBoss 7, so I assume you mean you were running EJBCA 4.0.16 on JBoss 5. That is another story :-)