Selecting a Serial Port for An External Modem for Use with Efax-gtk or Minicom

  • julianvb

    julianvb - 2014-03-31

    I am trying to check whether my USRobotics Sportser 33.6 Faxmodem is functional or not using Efax-gtk. But my computer houses an internal LSI Corp. WinModem. How can I ensure that it's not active and interferes with the external modem. What serial port should i specify in Efax-gtk?

    When I try to send a fax via Efax-gtk, I see the following error display.

    ** Beginning fax log: 1906 EDT 30 Mar 2014
    Socket running on port 9900
    efax-0.9a: 19:06:28 Error: can't open serial port /dev/ttyS4: Permission denied
    efax-0.9a: 19:06:28 failed page /home/jul/faxout/q11.pdf.001
    efax-0.9a: 19:06:28 finished - unrecoverable error
    Closing the socket
    ** Ending fax log: 1906 EDT 30 Mar 2014

    ** Beginning fax log: 1911 EDT 30 Mar 2014 **
    Socket running on port 9900
    efax-0.9a: 19:12:32 opened /dev/ttyS0
    efax-0.9a: 19:12:39 sync: dropping DTR
    efax-0.9a: 19:12:43 sync: sending escapes
    efax-0.9a: 19:12:49 Error: sync: modem not responding
    efax-0.9a: 19:12:49 failed page /home/jul/faxout/q11.pdf.001
    efax-0.9a: 19:12:49 finished - no response from modem

    1927 EDT 30 Mar 2014
    1942 EDT 30 Mar 2014
    1957 EDT 30 Mar 2014
    2012 EDT 30 Mar 2014
    2027 EDT 30 Mar 2014
    2042 EDT 30 Mar 2014
    * Ending fax log: 1906 EDT 30 Mar 2014 **


    Last edit: julianvb 2014-03-31
    • Chris Vine

      Chris Vine - 2014-04-11

      I doubt very much that your internal modem has a /dev/ttyS* device name. Looking at the output of dmesg might tell you where it is. However, the more likely outcome is that it is not recognized at all.

      The internal modem will not interfere with your external modem, whether or not it is working. You just need to know what serial port you have connected the external modem to, and select it in the settings dialog.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks