asus-launcher-config - custom software packs

Help
2008-04-09
2013-04-18
  • Christopher Lang

    Hi,

    I worked through page 22 and following in the SDK PDF "Xandros ASUS Software Development Kit: Chapter 2", and I am trying to properly install a  3rd party application into AsusLauncher.

    I ran into the following  problems:

    - I was really searching google and ask etc. for the package asus-launcher-config, which is obviously supposed to handle simpleui.rc xml snippets during installation of 3rd party apps. It is nowhere.

    - AsusLauncher does not seem to care about /var/lib/AsusLauncher/simpleui.rc. On my Eee PC (German) there is no such file. If I put one in, it seems that AsusLauncher does not care. strace reveals: this file is never being accessed.

    - If I put a simpleui.rc in /home/user/.AsusLauncher/simpleui.rc only this file is being used. So how are other 3rd party applications supposed to install themselves? Everybody mess around with the simpleui.rc in the home dir?? No, that will not work !

    - Putting anything into /opt/xandros/share/AsusLauncher/simpleui.rc does not make sense , it is overwritten every time an update is done.

    I would very much appreciate if Asus/Xandros could answer the following questions:

    - On current shipping Eee PC: How is a 3rd party developper supposed to properly install applications and handle the simpleui.rc?
    - Where is asus-launcher-config as per the SDK PDF?
    - What about /var/lib/AsusLauncher/simpleui.rc as per the SDK PDF ? Is this simply a bug ?

    many thanks
    best regards
    Chris

     
    • Chih-Wei Huang

      Chih-Wei Huang - 2008-04-14

      Did you follow the SDK guide exactly?

      The file /var/lib/AsusLauncher/simpleui.rc is created by /opt/xandros/sbin/update-launcher,
      as described in the guide.

       
    • Christopher Lang

      Yes, I followed everything in the SDK PDF exactly.

      I would appreciate if you could please answer the following question:

      Where can I find the package:

          asus-launcher-config

          ?

      I cannot update/download it using Add/Remove Software.
      It is *not* available on the on the server:

      http://update.eeepc.asus.com/p701

      many thanks

      Chris

       
    • Anonymous - 2008-04-29

      I am having the same problem.  /opt/xandros/sbin does not even exist...

      Anyone?

       
    • Lionel Sausin

      Lionel Sausin - 2008-06-05

      I can't find asus-launcher-config either, and this is a very bad thing indeed, as it would be the cleanest way of integrating apps on the eeePC.

       
    • Lionel Sausin

      Lionel Sausin - 2008-06-05

      Oh well, it seems the package is nowhere in the p701 distrib or updates, however I found it on the update repository for the p900 and p901 : http://update.eeepc.asus.com/p901/pool/asus-launcher-config_1.0.3-1_all.deb

      It seems to install fine on the p701 once you satisfy the deps (imagemagick and libxml2-utils).

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks