On Sun, Oct 3, 2010 at 10:31 PM, Samium Gromoff <_deepfire@feelingofgreen.ru> wrote:
On Sun, 3 Oct 2010 22:16:21 +0200, Juan Jose Garcia-Ripoll <juanjose.garciaripoll@googlemail.com> wrote:
> It seems that "configure" does not work when one of the directories contains
> a space in the name. Is this a known limitation?

I have never /ever/ tried to run configure with --prefix having spaces
in it.

On Linux due to cultural reasons.

On Windows -- because MinGW strongly encourages one to install itself at
disc:/MinGW, and one would have to be pressed hard to --prefix a package
into outside of MinGW's /.

I am not even talking about "prefix", which seems to work fine, but about the location of sources. If ECL's source tree is say in "/home/jjgarcia/some path/ecl/" then "configure" refuses to run because /bin/bash refuses to execute files (config.sub) which are located in paths with spaces. That seems like a bug in autoconf to me.

BTW, the fact that you have not ever done it does not mean that people haven't tried and been bitten by it... and complained ;-)


Instituto de Física Fundamental, CSIC
c/ Serrano, 113b, Madrid 28006 (Spain)