Out of Memory error

Help
2012-04-09
2013-04-29
  • Frank Bernhart

    Frank Bernhart - 2012-04-09

    Hi,

    I tried to extract 1.2 millions records out of 9 tables in three databases on the same server.
    Unfortunately, after ten minutes the query fails and I got following error message: java.lang.OutOfMemoryError: Java heap space
    Running the same query works when limiting the output of records by 100'000!
    That means the syntax of the query is correct
    In the internet, I found the advice to add -Xmx512M to the file Eclipse.ini, but there is no such file.

    What can I do?

    Thanks

     
  • Frank Bernhart

    Frank Bernhart - 2012-04-13

    Hi,

    thanks a lot for your helpful information. In fact, I discovered that the ini file on my pc is sqlexplorer.ini when I saw your syntax for eclipse.ini. I have put the maximum to 1024m, sql explorer didn't accept more like 1536m or 2048m. But anyway the query I have huild didn't work either. As I ran it the first time after having increased the memory / heap space, it was still running after 2 hours and unfortunately I had to stopp the query. When I tried a second time, I got the same error message again after ten or fifteen minutes. So it looks like that there is no way to make the query running for 1.2 million records.

    What d you think?

    Kind regards

     
  • Heiko Hilbert

    Heiko Hilbert - 2012-04-13

    Yes, for the standalone version of SQL Explorer the ini is sqlexplorer.ini.
    And the standalone version uses the bundled JVM which is a 32Bit JVM and you are using Windows, right?
    On Windows with 32Bit JVM user space is limitted to round about 1,5GB.
    So if you have a 64Bit Win OS with a 64 Bit JVM installed, try to rename the jre directory under sqlexplorer (or move it away) and then try to increase max heap size.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks