eclipsefp 2.4.1 installation problem

Help
pavel
2012-12-22
2013-03-22
<< < 1 2 (Page 2 of 2)
  • JP Moresmau

    JP Moresmau - 2013-01-04

    Are you sure the problem in Paths.hs for buildwrapper is not also present in the Paths.hs for scion-browser? You could try cabal clean and then cabal build to make sure all files are generated.
    The stacktrace you give shows that EclipseFP cannot read the output from scion-browser, which indicates a problem on scion-browser's side, not on the java side. But if it's not crashing any more, turning on debugging in the preferences for scion-browser should show you the error.

     
  • pavel

    pavel - 2013-01-04

    Now every project is clean and can be built within eclipse. For each project there is a file (I assume this is the Paths.hs for buildwrapper)

    <projectname>.dist-buildwrapper\dist\build\autogen\paths_"projectname".hs

    and paths are correct.

    prefix = "C:\Users\"username"\AppData\Roaming\cabal"
    bindirrel = "bin"
    getLibDir = getPrefixDirRel "helloworld-0.1\ghc-7.4.2"
    getDataDir = catchIO (getEnv "helloworld_datadir") (_ -> getPrefixDirRel "helloworld-0.1")
    getLibexecDir = getPrefixDirRel "helloworld-0.1"

    I am not sure to understand what you mean with Paths.hs for scion-browser (the same file or a different one?)

    scion-browser is still crashing so the only thing printed in the console is

    {"filepath":"C:\JavaProjects\.metadata\.plugins\net.sf.eclipsefp.haskell.browser\scion-browser-0.2-dbs\local.db","command":"load-local-db","rebuild":true}

     
    Last edit: pavel 2013-01-04
  • pavel

    pavel - 2013-01-04

    I should add that even if buildwrapper seems to work fine, from what I see from the event viewer, it is crashing (silently) quite often.

     
    Last edit: pavel 2013-01-04
  • JP Moresmau

    JP Moresmau - 2013-01-05

    I'm not talking about the Paths_projectname.hs for your own project, I mean for the buildwrapper and scion-browser sources that you build, if you build them from a source package you got yourself and not from EclipseFP.

     
  • pavel

    pavel - 2013-01-05

    OK. I downloaded the packages (scion-browser and buildwrapper) from hackage and installed them manually.
    The paths in paths_x.hs files seem correct

    bindir = "C:\Users\Username\AppData\Roaming\cabal\bin"
    libdir = "C:\Users\Username\AppData\Roaming\cabal\scion-browser-0.2.13\ghc-7.4.2"
    datadir = "C:\Users\Username\AppData\Roaming\cabal\scion-browser-0.2.13"
    libexecdir = "C:\Users\Username\AppData\Roaming\cabal\scion-browser-0.2.13"

    Scion-browser still crashing, buildwrapper apparently working (silently crashing).

     
  • pavel

    pavel - 2013-03-22

    In the end the problem was solved with a clean install of Haskell Platform 2012.4.0.0 and Eclipse FP 2.5.2. Previous attempts with 2.4.x were unsuccessful.
    After updating to 2.5.x it was even impossible to compile buildwrapper and scion-browser.
    Therefore I decided to try again a clean install and it worked.
    I guess there were some conflicting packages.
    Hope this could help people experiencing the same problem.

     
<< < 1 2 (Page 2 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks