EclipseFP Exporting plugin from source build

  • Michael Jones

    Michael Jones - 2012-02-02

    I am working from EclipseFP source, building and running it as a plugin (which spawns a child copy of Eclipse with the plugin in place).

    I'm currently using Eclipse 3.7.1 (codename Indigo) on OSX 10.7.2, and I've got the latest source as of this posting.

    I'd like to be able to export the plugin so that I can test to make sure everything works in a version of the 'final release', since I'm trying to help squash bugs.  And I like to keep bleeding edge. :)

    So this is a "I'm not used to eclipse" question, especially when it comes to plugin deployment. 

    I tried exporting the root plugin for net.sf.eclipsefp.haskell alone, via the Export Wizard, choosing Install Into Host, and I got the following error:

    Could not find the exported unit with id: net.sf.eclipsefp.haskell.browser version: 2.2.2

    Okay, so I decided to build all of them at once, and that failed with more dependency problems.  I've picked one or two of the others, like the browser just mentioned, and tried to build that alone, and got:

    Could not find the exported unit with id: net.sf.eclipsefp.haskell.browser version: 2.2.2

    I'm obviously not interpreting that correctly, because it seems to suggest it depends on itself.

    Got some hints? The Eclipse plugin documentation is vast, and the plugin deployment section is being unhelpfully nonspecific on this problem. 

    This was originally posted as a side message in this thread:

  • JP Moresmau

    JP Moresmau - 2012-02-02

    Not sure what you're trying to do here. To test you can just run EclipseFP in a workspace configuration, but you seem to iply that's working. If you want to output the plugins jar files to install into another Eclipse, what I use is the export wizard of the feature, not the plugin. net.sf.eclipse.haskell-feature -> open the feature.xml and launch the export wizard from the overview tab.

  • Michael Jones

    Michael Jones - 2012-02-05

    Okay, admittedly I was trying to export using the Export Wizard in the net.sf.eclipse.haskell plugin.XML file (the project without the -feature extension).

    So I tried what you suggested, and I still got this:

    Could not find the exported unit with id: version: 2.2.3

    I grabbed utterly fresh copies of eclipsefp and the other bits this morning.

    I'll see if I can fettle with a setting or something to make this go away.

  • Michael Jones

    Michael Jones - 2012-02-05

    okay, just for giggles, I wiped out my entire workspace folder, and downloaded eclipsefp into it, and imported it as an existing project.

    Then I tried to export.

    I got a different error message on trying to deploy to the existing eclipse as a plugin:

    Operation details
    Cannot complete the install because one or more required items could not be found.
    Software being installed: FP: Haskell support for Eclipse 2.2.3 ( 2.2.3)
    Missing requirement: FP: Haskell support for Eclipse 2.2.3 ( 2.2.3) requires 'net.sf.eclipsefp.haskell.scion.client 2.0.5' but it could not be found

  • JP Moresmau

    JP Moresmau - 2012-02-06

    yeah, I've checked the feature.xml and the dependencies are all off, they're obviously not recalculated when the plugins change, and I'm not really sure why the feature tries to import the same plugins that it exports… I've pushed to github a cleaner version


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks