SourceForge has been redesigned. Learn more.

"Server was not started or has died" error

  • Robin Green

    Robin Green - 2008-04-01

    I am using eclipsefp 1.104.0 on eclipse 3.3.0 on Fedora 8. I created a project, which worked, and imported 1 source file, which worked. I have tried to open the .cabal file in my project, but I keep getting this error:

    java.lang.IllegalStateException: Server was not started or has died

    By the way, pstree shows that haskellserver is running.

    • Leif Frenzel

      Leif Frenzel - 2008-04-01

      Hi Robin,

      there is a known issue with Cohatoe on Linux (I haven't really a good idea why but it shows up only on Linux for me, not on Mac). It produces the error message you see for the first one or two attempts to start the Haskell server; once the server runs, all works fine. I suspect it's a race condition during the startup phase of the plugin. That there is a haskellserver process running at this time is an interesting information.

      I'm working on this problem, and hopefully there will be a new Cohatoe+EclipseFP build with a fix soon.

      Thanks && ciao,

    • Hugo Ferreira

      Hugo Ferreira - 2008-07-26


      Just to add to this: I am using version 1.105 with Ubuntu 64bit.
      After a second attempt, editing source is ok. However, the problem
      for the cabal editor persists. Don't know if this will help.


      • Leif Frenzel

        Leif Frenzel - 2008-07-26


        thanks for the info :-)

        I'm afraid the problem that you see is different from the original one, though. The original problem should have been fixed in the latest version of Cohatoe (that fix was one of the outcomes of the Hackathon at the HaL event).

        In your case, the problem is because of the 64bit Linux. There is no Cohatoe build that supports 64bit. So actually all the functionality of EclipseFP that is written in Haskell (including the Cabal editor, but not the Haskell source editor) doesn't work on 64bit systems, giving an error message about the server.

        Thanks && ciao,

    • Hugo Ferreira

      Hugo Ferreira - 2008-07-29

      Hello Leif,

      Seeing as no one seems to be willing to provide you
      with a nice shinny x86_64 machine 8-(, I though I
      would try and see about compiling a 64 bit version
      for the plug-in, even if I know nothing of Haskell.

      So.. I pulled the sources and looked for C/C++
      code used in the OS/arch. dependent code. Found none.
      I only found instructions on using Haskell compilation.

      If you can give me instructions on how to build the
      Linux/Gtk stuff, I will compile it and place it where
      you want.

      Hugo F.

      • Leif Frenzel

        Leif Frenzel - 2008-07-29

        Hi Hugo,

        Great, thanks for the offer :-)

        There is actually no c++ code, it's all Haskell. The good thing however is that the Haskell code itself is portable, so there isn't any code change involved in compiling it on a Linux-64 system. You need GHC 6.8.2, and a couple of packages (including a patched version of hs-plugins).

        I'm currently wrapping up the current state of Cohatoe as version 1.0. It would be nice if we could include a linux-64 version in there. I suggest I create the necessary Eclipse fragment in the repo, and I'll put up some instructions in the wiki, so you can have a try :-)

        Thanks && ciao,

    • Hugo Ferreira

      Hugo Ferreira - 2008-07-29

      Ok then.
      Apologies for my ignorance, could you
      also post the wiki's link when you are done?

      Hugo F.

      • Leif Frenzel

        Leif Frenzel - 2008-07-31

        Hi Huge,

        yupp, sure :-) Actually, I would have already, but I'm currently having a problem with the repo at (seems to be a problem on the repo server with access rights). I've already mailed the admin, so I think it will be solved soon, and then I'll go on.

        Thanks && ciao,


Log in to post a comment.