EclipseFP "-package-conf is deprecated: Use -package-db instead"

  • Paul

    Paul - 2014-05-23


    Every time I try to run a project in EclipseFP (running Lubuntu 14.04) I get the following error "-package-conf is deprecated: Use -package-db instead". The compilation process freezes and I have to press "terminate", otherwise the build process runs forever.

    When I do a "cabal configure && cabal build" directly in the project folder (outside of EclipseFP) everything works.

    I checked all build paths. Everything seems to be correct (including GHC). My cabal version is GHC version is 7.6.3.

    I found another topic here on sourceforge (from February this year) mentioning the same error but the issue seemed to have gone away after refreshing the project and playing around with the build paths. I'm 100% sure that my paths specified in the preferences are correct.

    Any suggestions? Thx!

    My installation history:

    • installed haskell-platform via apt-get
    • installed buildwrapper, scion-browser, alex, happy, hlint, sourcegraph via the shell (no errors) using cabal install
    • downloaded eclipse 64 Bit for Linux
    • Added the eclipsefp repository as specified on the eclipsefp homepage
    • created a test project
  • JP Moresmau

    JP Moresmau - 2014-05-24

    This is a warning, you can ignore it. Your issues are unrelated.
    I run GHC 7.6.3 on Ubuntu 14.04, and everything is fine. Please run the test suite that comes with buildwrapper, it takes a few minutes to run and let you know if everything is ok.

  • Paul

    Paul - 2014-05-24

    ok, could you please provide some information on how to run the test suite that comes with buildwrapper? Thx!

  • JP Moresmau

    JP Moresmau - 2014-05-24

    You should just be able, inside the buildwrapper source directory, to run "cabal configure --enable-tests", "cabal build", and then "cabal test" should run the tests.

  • Paul

    Paul - 2014-05-25

    The tests didn't throw any errors.

    I started all over... removed .cabal and .ghc, then:
    1. sudo apt-get install cabal-install
    2. cabal update
    3. cabal --version -> cabal-install version
    using version 1.16.0 of the Cabal library
    4. cabal install buildwrapper
    5. In .cabal/bin/ I run ./buildwrapper --version -> buildwrapper executable, version 0.8.4
    using version 1.16.0 of the Cabal library
    6. cabal install scion-browser hoogle alex happy hlint
    7. cabal install sourcegraph -> here I notice that it downloaded cabal 1.20 Will this cause any problems?
    8. I downloaded and extracted eclipse, then I added the repository
    9. After a restart I created a test project and tried to compile it... eclipse freezes during compilation

    Btw, with freeze I mean that the message running executeable /usr/bin/ghc won't disappear

    One note, I don't run eclipse using admin rights...which you shouldn't do anyway, right?

    I'm somewhat desperate... Any suggestions? Thx!

    Last edit: Paul 2014-05-25
  • JP Moresmau

    JP Moresmau - 2014-05-26

    Make sure you're on the console view of your project in Eclipse when you launch compilation to see what may be happening.
    Then when Eclipse is frozen, run jvisualvm and obtain a thread dump of your Eclipse process. That may give me clue on where you're stuck, and hopefully why.

  • Paul

    Paul - 2014-05-26
    Post awaiting moderation.
  • Paul

    Paul - 2014-05-29

    @JP Moresmau: Any luck with deciphering the dump? Thx for your time!

  • JP Moresmau

    JP Moresmau - 2014-05-29

    There is nothing in the dump related to buildwrapper and building a project, so no I don't see anything there. There is build going on there.

  • Paul

    Paul - 2014-05-29

    well, the build is taking forever... I've tried to reinstall several times. No luck...

  • JP Moresmau

    JP Moresmau - 2014-05-29

    Well, as I said, there is no build activity in the thread dump you gave, it just looks like Eclipse is idle there, so I don't know what you mean. You talk about "running a project", then "building it". Maybe provide the exact actions you're doing with screenshots. Do you see anything in the console view? Do you have a .dist-buildwrapper/dist directory present in your project?

  • Paul

    Paul - 2014-05-29

    I do have a .dist-buildwrapper/dist directory present in my project.

    Here's what I did:

    1. File -> New -> Haskell Project
    2. Project Name : Test, create new project in workspace is checked, Components: executable is checked -> Finish
    3. In Project Browser: Navigate to Test -> src -> Main.hs
    4. main = putStr "test"
    5. Run -> Run -> GHCi Session -> Ok

    The console view shows:

    on the commandline: Warning:
    -package-conf is deprecated: Use -package-db instead

    There is no display of a console where I could enter commands as I could if I started ghci using terminal. For example there is no way to call the main function using console in eclipse.

    If I change main to putStr "test the console shows "lexical error in string/character literal at end of input"

    If I do something like main = putStr $ show [2,3] the following warning shows up in the console (as it should):

    Defaulting the following constraint(s) to type Integer' (Num t0) arising from the literal2'
    at /home/paul/workspace/Test/src/Main.hs:6:23
    (Show t0)
    arising from a use of show' at /home/paul/workspace/Test/src/Main.hs:6:17-20 In the expression: 2 In the first argument ofshow', namely [2, 3]' In the second argument of($)', namely `show [2, 3]'

    Running executable /usr/bin/ghc shows the "knight rider bar" in the lower left corner forever...

    So I guess it comes down to the problem that I can't see anything in the console. At work I use a different version of ghc and ubuntu in a virtual box and there I can enter commands interactively using the console in eclipse...

  • JP Moresmau

    JP Moresmau - 2014-05-29

    Ah ah!! Your first post about "building" sent me down a wrong track. Your issue is that some of the output of the console (including what you type) is not visible. I've had that bug before (as I said I have the same config as you) but I've never managed to reproduce it consistently. Usually a restart of Eclipse fixes it, and I've never found any reference to that issue anywhere else.
    Maybe you can try to change the colors for the console in the Eclipse preferences, see if it changes things. Also changing the GTK theme may help. I'll see if I can dig any more information. A priori we're not doing anything special, just writing info to the console...

  • Paul

    Paul - 2014-05-29

    Sorry for the confusion!

    I tried to change the eclipse theme (from GTK to classic) and played with the font color and background settings. Nothing changed...

    However, I can simply type stuff in the console such as :t main and I get the desired output. Also, I can type any function name and get a feedback. Sorry for all the fuss but I'm used to have the ghci style console view and thought there's something wrong with EclipseFP. Thx a lot for helping me out though!

  • JP Moresmau

    JP Moresmau - 2014-05-29

    Yes, it's still somewhat usable, but there is an issue, that's for sure... you should see the GHC messages...

  • JP Moresmau

    JP Moresmau - 2014-06-03

    I tracked down the bug causing the GHCi output to not show, it was in the EclipseFP code! Will be fixed in 2.6.0.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks