Problems with Perspective

  • Gustavo Ramiro Rivadera

    Hi Leif:
    I installed Eclipse, and the plugins for Haskell, but I have the problem already posted long time ago of error opening net.sf.eclipsefp.haskell.ui.haskell.perspective. following this forum, I suspect it was due to Java version, with was effectively 1.4.2, I downloaded version 1.6.0_03, but still isn't working. The configurations details in About..shows eclipse is still using the older version, how could I overcome this and use the newer?. I tried in windows/Preferences/Installed JRE, selecting only 1.6, but the error remains. I must also say that sadly I'm using Windows Vista, because I have a Toshiba laptop and couldn't get drivers for other OS.

    • Leif Frenzel

      Leif Frenzel - 2008-01-28

      Hi Gustavo,

      you can run Eclipse with a specific JVM via command line option: -vm <path-to-java.exe> If it works, the correct Java version must show up in the Configuration dialog (the Installed JREs preference is only for the JVM which Eclipse compiles against).

      You can also enter the command line arguments into the eclipse.ini file, then they are used automatically. Note that the eclipse.ini needs always one command per line, so it must look like:

      ... possibly other options

      Hope this helps,

    • Gustavo Ramiro Rivadera

      Hi Lei
      Thanks for your quick answer! It worked perfectly, despite Windows Vista, :).


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks