Compile Failing after upgrade

Help
2012-03-04
2012-12-06
  • Doug Ransom

    Doug Ransom - 2012-03-04

    Just upgraded this morning to latest build wrapper and scion-browser that eclipse said was available (on os x):

    configuring because setup_config too old
    cabal: At least the following dependencies are missing:
    hunit -any

    What am I doing wrong?

    Cabal file in my project:

    name:           fuzzy
    version:        0.1
    cabal-version:  >= 1.2
    build-type:     Simple

    executable fuzzy
      hs-source-dirs:  src
      main-is:         Main.hs
      build-depends:   base >= 4,
                       hunit
      ghc-options:     -Wall

    library
      build-depends:   base >= 4
      hs-source-dirs:  src
      ghc-options:     -Wall

     
  • Doug Ransom

    Doug Ransom - 2012-03-04

    Case error on HUnit, not sure how that arose.

     
  • JP Moresmau

    JP Moresmau - 2012-03-04

    There was a bug in a previous version (2.2.2 and before) where if you used a quick fix to add a package dependency, the package was added lower cased. Probably an instance of that that you didn't notice before.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks