Installing EclipseFP 2.3.1 on OSX Lion fails

Help
Anonymous
2012-08-03
2012-12-06
  • Anonymous - 2012-08-03

    Steps followed:

    Download Eclipse

    The following is a copy of the about screen

    Eclipse IDE for Java Developers
    Version: Juno Release
    Build id: 20120614-1722
    (c) Copyright Eclipse contributors and others 2000, 2012.  All rights reserved.
    Visit http://eclipse.org/
    This product includes software developed by the
    Apache Software Foundation http://apache.org/
    

    I follow the other instructions on the EclipseFP install page, accept the license, and click "Finish". After waiting a moment, install fails with the following message:

    Cannot complete the install because one or more required items could not be found.
    Software currently installed: FP: Haskell support for Eclipse 2.3.1 (net.sf.eclipsefp.haskell.feature.group 2.3.1)
    Missing requirement: Haskell Plug-in 2.2.4 (net.sf.eclipsefp.haskell 2.2.4) requires 'bundle net.sf.eclipsefp.haskell.haddock 0.0.0' but it could not be found
    Cannot satisfy dependency:
    From: FP: Haskell support for Eclipse 2.3.1 (net.sf.eclipsefp.haskell.feature.group 2.3.1)
    To: net.sf.eclipsefp.haskell [2.2.4]
    
     
  • JP Moresmau

    JP Moresmau - 2012-08-03

    I've checked, there is no requirement from the haskell plugin to the haddock plugin, which doesn't exist. I have tried a clean install on Juno with no issues, but I'm on windows, not Mac. Maybe you can try to install EclipseFP 2.3.0,  then upgrade to 2.3.1. I take from your message that it's a new Eclipse and no previous install of EclipseFP? You're sure your workspace wasn't existing before, and Eclipse may have kept some obsolete dependencies?

     
  • Anonymous - 2012-08-03

    How would I go about installing EclipseFP 2.3.0?

    It is a new Eclipse; I don't think I have ever installed Eclipse on this machine, but I could be mistaken. However, I just "rm -rf"ed my workspace and tried again, and encountered the same issue.

     
  • Anonymous - 2012-08-03

    I ask because there seems to be no easy way to install an older version through Eclipse, and there are no instructions for installing from source.

     
  • JP Moresmau

    JP Moresmau - 2012-08-04

    Of course there is, there's a checkbox on the install new software wizard that asks you if you want only to see the last version or all versions. I'm not sure it would solve your problem anyway, since that very plugin has not changed since but it's worth a try. The .haddock plugin we've removed maybe in 2.3.0, so maybe install a previous version (2.2.4) and then upgrade to 2.3.1.

     
  • Anonymous - 2012-08-04

    I'm surprised I missed that. Thanks.

    2.3.0 installed without a hitch. I'm currently installing BuildWrapper and Scion-browser, and these seem to be going fine. I'll try upgrading later.

     
  • Anonymous - 2012-08-04

    Installing 2.3.0 and then upgrading to 2.3.1 seems to have worked. I don't know why.

    Thanks.

     

Log in to post a comment.