Preview not working, built XAP not displaying

  • Joseph Jones

    Joseph Jones - 2009-03-28

    OK, two issues here after installing the latest Eclipse4SL on Mac OS X 10.5.6.

    1) When I open my project, the XAML preview displays nothing.

    2) When I run my project from Eclipse (or directly) the Silverlight Control just sits on the spinning blue balls loading screen. It hits 100% and then does nothing.

    I am using the latest Mono, the latest Silverlight Runtime 2.0.40115.0 ad the latest tools form Eclipse4SL.

    Not sure what is the issue. I see nothing in nor anyplace else that might point to the issue.

    • Yves YANG

      Yves YANG - 2009-03-30

      Can you test to create a new project?

      We have noticed a bug of the build if the bin and obj are missing.

      Best regards
      Yves YANG

    • Joseph Jones

      Joseph Jones - 2009-03-31

      Nope, they both have the same issue. And they both have Bin and Obj folders.

    • Rick Downs

      Rick Downs - 2009-04-24

      I have the exact same problem. Mac OS X, 10.5.6, latest Eclipse, tried with both Silverlight 2 and Silverlight 3.

      In my case, the XAML preview works (but stopped working for awhile and came back when I reinstalled Eclipse), but when I run the HelloWorldTutorial, built from scratch, nothing comes up in the browser. The .xap file isn't loaded.

      • Yves YANG

        Yves YANG - 2009-04-25

        Could you indicate us the version of eclipse, eclipse 3.4.x or eclipse3.5M6?

    • Rick Downs

      Rick Downs - 2009-04-25

      This is the version I'm using:

      Version: 3.4.1
      Build id: M20080911-1700

    • Rick Downs

      Rick Downs - 2009-04-27

      Just updated to 3.4.2 M20090211-1700, and now XAML preview is gone again, still doesn't load .xap file.

      • Yves YANG

        Yves YANG - 2009-04-28

        It is very strange.

        Please check all Pre-requisites are installed step by step:
            *  Mac X 10.5 (or above)
              - Mac OS X includes the full version of J2SE 1.5, pre-installed with the Java Development Kit (JDK) and the HotSpot virtual machine (VM), so you don't have to download, install, or configure anything. If it doesn't work, you can download from here.
            * Mono
              - Select Mac OS X platform
            * Eclipse 3.4.1 (Mac OS X)
            * Silverlight 2 Runtime (2.0.31005.0 or above)
                  o Go to this page, at the right side, click on the "Mac runtime".

        The Silverlight 3 is not supported.

        Best regards
        Yves YANG

        • Rick Downs

          Rick Downs - 2009-04-30

          Yep, have all that. Still doesn't work. Oh well...

          • Yves YANG

            Yves YANG - 2009-05-17

            It seems there is the Silverlight SDK is missing. You need reinstall it. Make sure Silverlight SDK is in the list of plugins to install.

    • paul galvin

      paul galvin - 2009-05-16

      Hi there, on running the silverlight example DataGridTutorial I press run with eclipse and it simply pops up notepad indicating 'The filename, directory name, or volume label syntax is incorrect.

      Microsoft(R) Silverlight(TM) Development Utility. Version
      Copyright (c) Microsoft Corporation.  All rights reserved.

      Chiron serving 'E:\devapps\projects\DataGridTutorial.Web' as http://localhost:15215/
      14:26:19 400       646 [unknown] [Unparsable bad request]

      If I load the http://localhost:15215/DataGridTutorialTestPage.html
      all works fine.

      The Chiron instance, XAP file seems fine but I may be missing something obvious.

      • Yves YANG

        Yves YANG - 2009-05-17

        Are there some logs? Please take a look at the "Error view".

    • paul galvin

      paul galvin - 2009-05-16

      I should add, any help on my DataGridTutorial issues would be welcome.




Log in to post a comment.