Assembler source files?

Rick Ball
  • Rick Ball

    Rick Ball - 2008-11-11

    I'd like to use some assembly language source files in Eclipse/SDCC - after installing (on WinXP), I tried adding a .asm file, and it complained about not finding the 'as51' command.  So I changed this under the project properties to match the name of the assembler provided with SDCC (asx8051), and also added a space after ${OUTPUT_FLAG} in the command line pattern (since the asx8051 seems to want this), and now it executes, but it can't seem to create the output file:

    Invoking: SDCC Assembler
    asx8051  -o "movex.rel" "../movex.asm"
    movex.rel: cannot open.
    make: *** [movex.rel] Error 1
    make: Target `all' not remade because of errors.

    If I run the command from a shell it does the same thing - I noticed that the working directory ('Release') is marked read-only (and if I try to make it writable it magically changes back to read-only????), could this be the problem?  If I just run the command in the source directory (removing the ../ from the input file, of course), it works fine.

    Can anybody help?


    -- Rick

  • Bissong

    Bissong - 2010-04-20


    I'm sure you're not interested in my answer (2years later) but anyway… I began to work with sdcc and eclipse few months ago and I now need to use some assembly file.
    For your problem, by default Eclipse uses syntax ${COMMAND} ${FLAGS} ${OUTPUT_FLAG}${OUTPUT_PREFIX}${OUTPUT} ${INPUTS} but asx8051 should not receive any information about output hence ${COMMAND} ${FLAGS} ${INPUTS} makes it work.
    But one problem remains, asx8051 creates the object (.rel) in the same directory as the asm file, but Eclipse needs it in the Release folder to link it, I've not found yet how to move it to that directory. If anyone could help me, I'd appreciate that.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks